Hazards/turn signal issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-01-05, 09:31 PM Thread Starter
Registered User
Join Date: Aug 2005
Posts: 1
Hazards/turn signal issue

Hey folks!

I'm definitely a newbie to the Ford family, and I just recently got a 97 T-bird in my hands. I'm having a problem though. (And yes, I did use the search function here, to no avail.) My hazard lights dont kick on when I hit the button. I didn't think much about it until my turn signals died tonight.

Weird thing though: When the turn signals died, the hazards then worked, but my dash only had the left signal blinking, not the right. I changed fuses (even though the old ones didn't look blown, and it didn't help. 5 min later, the turn signals worked again and my hazards were out.

Any tips on where to look for a flasher unit/fuse that ISN'T in the fuse panel under the steering column? Has anyone had this issue before?
joec is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome