Hesitating problems...computer maybe???? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-26-07, 08:52 PM Thread Starter
Registered User
Join Date: Sep 2007
Posts: 1
Hesitating problems...computer maybe????

Hey folks, im new on here and i am seeking desperate help for my Tbird turbocoupe. Its an '85 and i am having some trouble. Well, when i am driving the car it seems to drive ok until i hit about 3k rpm. when the boost kicks in the car seems to hesitate a lot like lack of fuel or spark. Well, I have replaced numerous partls like turbo intake gasket bacause it had a bad vaccum leak, put an MSD coil, new ingition module, and it even has a new vam air sensor. Well, me any my buddy have been tinkering with it for a while now and ran out of ideas of what could be wrong. we pulled the knock sensor and when i try to start it up, it dont start, and even when idling it will seem so miss a bit and when you revv it up, it still cuts out at 3k rpm with no load even. So, i thought it might be the tps. we unplugged it and it seems to run a lot better without it plugged in. the hesitation stops but when u let the revvs down, it will wanna die. Could that sensor be the problem or possible wiring???? So, I have also replaced the fuel pump with a Walbro pump and it still did the same. So, we were thinking, when something to the engine is unplugged the car runs crappy or a little better. Out last conclusion was that it HAS to be the computer, eec. Anybody have these sort of problems before???? If anyone has any suggestions please send em my way as i am in desperation for advice on to fix my car. Thanks a whole lot!!!

Larry M.
Turbotbird85 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome