Iac/Maf question - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-27-2007, 22:08   #1 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 6
Iac/Maf question

My car began idling high on startup(2500 rpm). So, I cleaned the iac and maf. The car ran perfect for half an hour. Then, the check engine light came on and it idled high again(1500 rpm). Since I cleaned both, I don't know which is the problem. Which should I replace first? Thanks.
92Bird is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-28-2007, 23:00   #2 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 11
Re: Iac/Maf question

Well I just had a similar problem with my idle going up to 2k and it turned out to be the IAC. I dont know how to test them either.
Turned out to be $60 and everything was fine.
Sounds like that might be your problem too.
~Rich
dadstoys2 is offline   Reply With Quote
Old 08-28-2007, 23:06   #3 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 6
Re: Iac/Maf question

Replaced my iac, and it seemed to have taken care of the problem. Now when the car gets up to operating temp, the check engine light comes on. I also can hear a faint whizzing/whirring noise that wasn't there before.
92Bird is offline   Reply With Quote
Old 08-29-2007, 01:08   #4 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 11
Re: Iac/Maf question

Hmmm. Sorry that I cant help with that without a bit more info. Try checking out any codes that the computer might be throwing. Check engine light could come on from alot of things.
O2 sensors are a big cause of check engine lights but that would have nothing to with the noise you described.
~Rich
dadstoys2 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:01.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.