Interior light problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
¬Ľ Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-06-2004, 18:21   #1 (permalink)
Registered User
 
Join Date: Oct 2004
Age: 26
Posts: 1
Interior light problem

Hey guys, I just got a 1992 Thunderbird 3.8 V6 a few weeks ago as my first car.......Has quite a bit of miles on it (175K) but it runs like a dream, besides the engine mounts being shot.

But I have a few problems with it: for one, when I bought the car the interior lights weren't working. When I took her home and checked the fuses, I noticed that one of them was gone, and it was the interior lighting one. As soon as I popped that fuse in, the lights stayed on, and boy did it look nice. But I closed the door and waited for a good minute, and the lights stayed on. I tryed starting her and then turning her off, but nothing. The door switch isn't the problem because I tested that.

When I did test it, the lights would stay on for a bit while the door was closed, but would make a click noise and flash the lights off very quickly then get them back on.

So waht could it be? I scourged the internet and these forums and found no good answer. I read maybe resetting the computer would fix it, but I don't exactly know how to do that....any help would be greatly appreciated guys, thanks.
JeffShap is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Ford Escape liftgate problem and steering column problem macollin Ford Escape | C-MAX | Mercury Mariner Forum 0 09-23-2004 07:27
87 Bronco-Fusible link problem, maybe? HELP ladyferricher Ford Bronco Forum 1 09-14-2004 21:16
Steering/wheel alignment problem mike98AUXR6VCT Suspension | Wheels&Tires | Brakes 10 04-23-2004 04:33
Need Advice about idle problem after timing job... pgt96w99k V6 and Hot4 Tech 0 08-02-2003 14:45
EF Wiper problem Darren.Parish General Tech 5 03-19-2002 18:35

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:57.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.