MAF and MAP? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-06-09, 09:39 PM Thread Starter
Performance...all the way
 
speaker_king's Avatar
 
Join Date: Oct 2008
Location: knoxville TN
Age: 28
Posts: 405
Question MAF and MAP?

I just found out that my car has both MAF and MAP sensors. Could the MAP sensor be whats causing it to idle to low sometimes? To where it kinda bounces. When i replaced the EGR valve it helped ALOT.


1993 Thunderbird LX, Stroked 4.2L Complete Cold Air Intake, AOD w/stage 2 shift kit(soon to be 5speed)
speaker_king is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-07-09, 08:10 PM Thread Starter
Performance...all the way
 
speaker_king's Avatar
 
Join Date: Oct 2008
Location: knoxville TN
Age: 28
Posts: 405
Question Re: MAF and MAP?

On the autozone and O' riellys website it lists the location as under hood, mounted on firewall, rear of strut tower on passanger side. But i went to auto zone and O' riellys and when they look it up on their computer it says that my car isnt equiped with it.

Does it go by a diff name? (and no, not the ACS)

1993 Thunderbird LX, Stroked 4.2L Complete Cold Air Intake, AOD w/stage 2 shift kit(soon to be 5speed)
speaker_king is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome