odometer and speedometer not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-01-2012, 07:07   #1 (permalink)
Registered User
 
Join Date: Jul 2012
Posts: 2
odometer and speedometer not working

Hi, I have owned the car for 3 years ( 96 T-bird 4.6L V8 ) inherited it from my grandfather who passed away. i have experienced speedometer jumping from time to time and it has always gone back to normal. Thought it might be a temperature issue -- winter vs summer -- since i live in Midwest and this has always been an outdoor car. the car has currently been without speedometer and odometer not working for 9 days. another member suggested a VSS Generator. i do have a " engine light" on - but my mechanic had checked that and it was something to do with the idle control motor ( $ 500 to fix ) . Any suggestions would be great.

Jeff
96t-bird is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-01-2012, 09:14   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,844
Re: odometer and speedometer not working

The idle control won't affect the speedo. There's a test sequence to see if it's the sensor wiring or speedo itself. Many times it's a connection problem. There's possibly a code stored and Autozone will check for free.
__________________
Bert
Bert is offline   Reply With Quote
Old 08-02-2012, 12:52   #3 (permalink)
Registered User
 
Join Date: Jul 2012
Posts: 2
Smile Re: odometer and speedometer not working

ok, Thanks -- I will check that out at Autozone
96t-bird is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:45.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.