Running problems with 95 Bird 4.6L... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-12-04, 09:28 PM Thread Starter
Registered User
Join Date: Sep 2004
Age: 38
Posts: 1
biggrin Running problems with 95 Bird 4.6L...

My brothers Bird blew its heater core this summer. Since it was hot out we just bypassed it. Now that its getting cold he put in a new one today. Which i might add was interesting to say the least. Anyways....

We got it all back together and whatnot. Now i'm not sure if this is going to be related to having the whole interior of the car tore part or not. But we got it put back together everything worked. Ran great for about 15 min. Then it started missing. Its only missing on the right side you can tell from the dual exhaust that the right is running really rich. The car will start right up but its just running poorly. I was thinking maybe a ground got unhooked and it might be causing it. But we never unhooked any grounds. Chased wires and whatnot and made sure they were all there and intact. Checked under the hood where we were working at and nothing looks disturbed to say the least. Thats why i'm not sure if this problem is related to replacing the heatcore or not.

I'm thinking maybe the coilpack is going bad on that side. The bonehead doesn't have a book for it so i'm wondering if there's a way to check the coilpack to see if its failing or not. Or any other hints or tips on what we can check. I'd like to get this thing running tonight cause i sure as hell do not want him driving my VW to work tomorrow. 1 this car will walk his bird all over hell and back and 2... he's been in 3 accidents and if he wrecks my car he knows i'll kill him :D
85vdub is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 V8 'Bird Zubrovka Ford Thunderbird Forum 2 06-17-04 10:18 PM
Oil pressure problems! Bounce Ferret! Inline 6 Tech 12 02-27-04 05:22 AM
Car running rough in heat?? RaceCraft General Tech 7 02-19-04 05:05 AM
sub problems xespack Audio And Security 52 04-28-03 02:59 AM
Any problems with manual trans? jambo Trans | Driveline 7 08-03-00 09:53 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome