Sick Bird - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-21-14, 12:40 AM Thread Starter
Registered User
Join Date: Feb 2014
Posts: 3
confused Sick Bird

I bought a 93 thunderbird LX 3.8 V6, it has been sitting up for about 2 years I was told, said that is ran great when he parked it. It just need upper and lower ball joints on front. I had to replace the fuel pump after car would not crank, changed oil and filter and transmission fluid. Drove the car around the block. Then I parked the car got it up on stands waiting to change the ball joints. Next day I went out and cranked the car, it sounded funny, sounded as though the rocker arms were chattering, or a rod was hitting the valve cover and would not stay running, according to the oil pressure guage, oil pressure was good,(don't know if it was true or not). Any ideas of what happened over night, I have none. Please give me something to look for. Thank you
cajones65 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-21-14, 07:10 PM
Dazed and Confused
CatSkinner's Avatar
Join Date: May 2012
Location: Upstate New York
Posts: 5,282
Re: Sick Bird

You really need to go digging for this. For starters, you may be able to pull the oil pressure sensor and put a real gauge on it. Could've broken loose corrosion, change in oil of the proper weight may unmask hidden problems, I'd start with pulling the valve covers and see what the valve train looks like.

Chewing on asphalt and drinking dinosaur wine
CatSkinner is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome