Transmission surging or slipping - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-08-2011, 09:40   #1 (permalink)
Registered User
 
UntamedFreya's Avatar
 
Join Date: Oct 2011
Posts: 1
Transmission surging or slipping

Hi I need help with a problem. I got a -95 TB and the transmission keeps slipping and is hard to go into gear. I had someone tell me it was the speedwinder cable or speedgear cable??? and that I will need a transmission rebuild. Now I wonder, what it can be, and if I can do it without a rebuilds. Can it be the shifter cable and then can I do it and not rebuild. Very great full for any help or advice.

Thanks

Freya

Last edited by UntamedFreya; 10-08-2011 at 09:41. Reason: miss spelling
UntamedFreya is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-08-2011, 16:18   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,703
Re: Transmission surging or slipping

Fluid full, nice and clean? Autozone will pull codes for free. Does it drive okay at any time at all?
__________________
Bert
Bert is offline   Reply With Quote
Old 12-01-2011, 20:26   #3 (permalink)
Dark Lord of the T-bird
 
Join Date: May 2011
Location: Canada eh?
Posts: 11
Re: Transmission surging or slipping

i have a similar problem minus the slipping sometimes the tranny does not go into park from reverse and i cycle through the gears and force it into park and it works. but ya i think it has something to do with the shifter cable being possibly either loose. check your shifter cable all tthe way to the tranny and ensure it is not loose. Also i would recomend you put the lucas oil tranny fix stuff in there (drain your fluid and change the filter and put a full bottle of lucas tranny fix with the new fluid in for full affect) i swear by lucas and they have never let me down. even if it doesn't fix the slipping it will atleast give you more time.
__________________
1993 Ford Thunderbird 3.8L OHV V6 non supercharged, 4-speed AOD transmission, 140 - 145 HP stock, currently 156 HP with performance cold air intake and other mods
Thunderchickin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:28.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.