Turn signal issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-11-10, 08:26 AM Thread Starter
Rocket Bird
Join Date: Nov 2010
Location: Ontario
Posts: 34
eek Turn signal issues

HI everyone I just wanted to tell you about a turn signal problem I was having and how it was fixed.
Well basically the issue was that I would use my turn signal and I would hear a partial click sound and then nothing. The light never came on to blink. The weird thing was the initial click-ish sound like it was getting power but something was not connecting. Well I went to the flasher fuse and I replaced it. This was not the problem. So I went to the next thing, the actual fuse for the turn signal. It looked ok so my next thing to look at was It was the turn signal cam thinking that maybe something was streached out and no longer making the connection. So I replaced it and still nothing. Puzzled I asked a good friend of mine and he mentioned the fuse. I had looked at it earler it looked ok and there was no burn marks in it but figured what the hell replace the little bugger and low and behold my turn signal lights were working again. what a head scratcher that was LOL hope this helps someone out.
Rocketrockel is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-12-10, 09:15 PM
2002 F150 XLT
Bert's Avatar
Join Date: Nov 2008
Location: Oregon
Posts: 10,249
Re: Turn signal issues

Thanks for the update. That should help someone. Being in the repair business, I've had that experience before.

Bert is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome