Is this Weird? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-19-08, 04:19 PM Thread Starter
Registered User
 
crazyeyeschase's Avatar
 
Join Date: Sep 2008
Location: Newton,KS
Age: 28
Posts: 90
Question Is this Weird?-Boost pressure question

OK, this might be a stupid question, but I have been trying to pay attention to my car more and figure things out.

My car has been running about 5 psi boost since I bought it, and I've been wanting to increase that. Just today I was driving home and managed to glimpse at the guage, and it was at about 9 psi. I was like wth, so I let off the gas and hit it going about 70. Again, the boost hit about 9 psi so I was like hey cool, and when I got into town I decided to try again, and again I got 9 psi. Now I haven't done anything to alter the engine or turbo in the last few days, so I'm somewhat concerned that I should look for something wrong.

My vacuum hoses have been popping off. I just bought new hoses, but I haven't replaced them yet. I'll see what it does with a better seal.


Last edited by tbird100636; 11-20-08 at 09:32 AM. Reason: Spelling and punctuation
crazyeyeschase is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-22-08, 08:44 PM Thread Starter
Registered User
 
crazyeyeschase's Avatar
 
Join Date: Sep 2008
Location: Newton,KS
Age: 28
Posts: 90
Re: Is this Weird?

bump
crazyeyeschase is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome