1993 Cougar XR7 5.0 HO V8 no power - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Mercury Cougar Forum Forum for discussion of the Mercury Cougar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-13-2009, 07:48   #1 (permalink)
Registered User
 
Join Date: Feb 2009
Posts: 7
frown 1993 Cougar XR7 5.0 HO V8 no power

Car was running great until I did a standard tune-up (plugs, wires, cap, rotor button, fuel filter, air filter) then it started to sound like it was missing and it was hesitating. Now when I step on the gas, I have no power. She idles ok. Please help!
Fireman1144 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-16-2009, 11:31   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,474
Re: 1993 Cougar XR7 5.0 HO V8 no power

Hmmm. I don't mean to sound off-beat or anything, but the wires were installed tight and in the correct firing order? Plugs were gaped correctly before they were installed?
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Old 02-17-2009, 14:30   #3 (permalink)
Registered User
 
Join Date: Feb 2009
Posts: 7
Re: 1993 Cougar XR7 5.0 HO V8 no power

Got it figured out. #3 Catalytic converter was really clogged and the timing was slightly off. Fireing order was right( verified three times), plugs gaped right (verified twice), wires on tight (crimped to ensure). Thanks for the input though.
Fireman1144 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:07.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.