2 issues.... need help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Mercury Cougar Forum Forum for discussion of the Mercury Cougar.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-20-10, 02:26 PM Thread Starter
Registered User
 
Join Date: Sep 2010
Posts: 6
2 issues.... need help

I have a 95 cougar 89k miles and i have been having issue with it recently. i have taken it to a shop and had them run diagnostics on it and they told me i need a new dpfeh hose and that is why it has a check engine light on. i want to verify this and i have heard of people using a paperclip to pull error codes. Which ports do i bridge to get the cel to blink and give me the error code?

Second issue. i went to get the emissions done, they guy told me that the there is something wrong with o/d on my car and that was one of the reasons it did not pass (referred me to transmission shop he knows of, makes me think he is trying to get money out of me). since ive been driving the car, it has always had this issue where i will be driving down the road steady on the gas at about 50-55 mph and the rpms will jump to 2k-3k but the car does not accelerate. it will not accelerate until the rpms fall back down. if you press the gas before the rpms drop, it will rev more but go nowhere. the mechanic told me that the transmission is slipping, but that contradicts what the guy at the emissions place told me. i have had the transmission flushed and that seemed to help for awhile but the problem continues and i cannot get an answer from anyone that seems to make sense. i am willing to put a new/junkyard transmission in it and i have a place and resources to do it, but i want to make sure that its not something that will be easier to fix.

any help would be great!

csm600 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-20-10, 02:39 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 2 issues.... need help

If you have the 4.6, it has OBDII and Autozone will pull the codes for free. If it isn't, here's how to pull codes. Ford Fuel Injection » How To Run a Self-Test

Bert
Bert is offline  
post #3 of 5 (permalink) Old 09-20-10, 02:45 PM Thread Starter
Registered User
 
Join Date: Sep 2010
Posts: 6
Re: 2 issues.... need help

cool, i didn't think i could use an obd2 reader on it. My buddy has one so i'll try that.


Anyone have any ideas about the other issue? I'm thinking it could be a bad transmission, but i'd rather know for sure before i drop a new trans in it.
csm600 is offline  
post #4 of 5 (permalink) Old 09-20-10, 04:39 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 2 issues.... need help

See what codes you get first.

Bert
Bert is offline  
post #5 of 5 (permalink) Old 09-21-10, 08:59 AM Thread Starter
Registered User
 
Join Date: Sep 2010
Posts: 6
Re: 2 issues.... need help

will do. thanks
csm600 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome