2000 Cougar Fuel Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Mercury Cougar Forum Forum for discussion of the Mercury Cougar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-12-2009, 08:29   #1 (permalink)
Registered User
 
Join Date: Jul 2009
Posts: 1
2000 Cougar Fuel Problems

I am working on a 2000 I4 Mercury Cougar. The fuel pump works (tested with an alternate power source) but does not appear to be getting power from the ECU.
Thus far I have done the following to trouble shoot the issue:

The first thing I checked was the fuel pump fuse. It was good.

We then moved on to the fuel pump relay. As I did not have an OHM meter to check it we plugged it into the horn relay's spot as they are identical (per the drawing on the side of the relay) and the relay worked there.

I checked the fuel safety switch to ensure that it was not tripped. Once I found it to be depressed I disconnected the harness from switch and bypassed it by inserting a wire into each side of the connector.

Does anyone have any additional ideas as far as trouble shooting the issue goes?

I am not sure if this may be a sign of an ECU failure or if it is typical of these cars but, the gauges (speedometer and tach) do peg when the power is cycled through the ignition switch.


Any help would be greatly appreciated.

Erick C.
talclipse is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 13:50.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.