94 Cougar / Where to start - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Mercury Cougar Forum Forum for discussion of the Mercury Cougar.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-09-2009, 09:08   #1 (permalink)
Registered User
 
Join Date: Aug 2009
Posts: 1
confused 94 Cougar / Where to start

I bought a 94 cougar (3.8 v6) for my gf for $400. It needed a new steering rack- which I just finished installing a week ago. It runs good but soon noticed the following problems....

engine light is on,,,,

The coolant temp sensor may be bad since it reads normal but the upper radiator hose is pressurized which leads me to believe it needs a new thermostat as well,,,,

The radiator fans do not run- I tried turning the AC on but the fans still didnt kick on and the AC compressor locked up and the belt was smoking,,,,

I ran the codes the car pulled...

and got 3 codes,
one that points at the egr sensor
one that points at the air charge sensor
and one that states hard faults present...

Which I was told -hard faults present could mean the computer needs replaced.

I would like to get the fans running so thecar can be driven and I will get the sensors replaced when I can.

But I dont know where to start?

Should I replace the thermostat/tep sensor first ,
or replace the relay module that controls the fans/AC?

Any help is appreciated!
deezdrama is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2009, 14:59   #2 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 3
Re: 94 Cougar / Where to start

The first thing I would do is eliminate the fans as being the culprit by locating the hot wire going to the fans and connecting it directly to the battery. If the fans work, then you can eliminate them and move on the the sensors. If they still will not work then you have located the problem with the fans.
351LSC is offline   Reply With Quote
Old 10-18-2009, 15:21   #3 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,756
Re: 94 Cougar / Where to start

Here is the wiring diagram in 2 parts. How hot does it get? The cooling system is pressurize and the hoses will fell hard when the engine is hot. The fans don't come on until the engine gets about ¾ way up the gauge. The A/C compressor must be froze up. The compressor has to build up pressure to make the fans come on. If you connect the red/yellow and pink/light blue wires together the fans should work if everything is okay other than the A/C compressor.

Keep track of the codes and clear them to see if they come back. Disconnect the battery for 5 min. and then recheck. What codes did you get?
Attached Images
File Type: jpg Fans1.jpg (76.7 KB, 3 views)
File Type: jpg Fan2.jpg (87.4 KB, 4 views)
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:07.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.