I'm thinking of buying a Cougar, but it has a problem... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Mercury Cougar Forum Forum for discussion of the Mercury Cougar.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-07-09, 10:21 PM Thread Starter
Registered User
 
Join Date: Jul 2009
Posts: 1
I'm thinking of buying a Cougar, but it has a problem...

It's a '94 4.6L Cougar with about 140,000miles. It seemed to drive just fine at first. However, when I floored the throttle to check tranny kick-down and passing power the tranny shifted, then nothing. The car would not accelerate, the rpms would not rise, until I began to let off the throttle, then the car would accelerate. It tried this a couple more times with similar results.

However, after turning around to head back to the dealer. I did a full throttle run from a stop and it seemed to work fine after that. Any idea what the problem is?

Thanks

hobbie2k is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome