Transmission Range Sensor ( help !!! ) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Mercury Cougar Forum Forum for discussion of the Mercury Cougar.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 10-14-09, 04:18 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 3
Transmission Range Sensor ( help !!! )

New to the forum and like it :) I'm a Ford Guy and need some help with sons car. 2000 Cougar v6 2.5 i think. Car Jerks so badly that it feels like the transmission is jerking in and out of hi and low gears... unbelievable .. Had the system tested and it comes up trs and just bought one... not sure the proper steps to install... any help would be most appreciated.

mrmarsh68 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 10-14-09, 05:53 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: Transmission Range Sensor ( help !!! )

From the Ford manual this is the installation procedure. Taking it out is just removing the bolts and then the sensor. The installation and tool. If you remove it in the neutral position, you won't have to worry about setting it to neutral before installing it.
Attached Images
File Type: jpg Trans.jpg (68.3 KB, 67 views)
File Type: jpg Trans2.jpg (21.8 KB, 61 views)
Bert is offline  
post #3 of 13 (permalink) Old 10-15-09, 06:36 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 3
Re: Transmission Range Sensor ( help !!! )

thanks for the info.... unclear about the special tool and what is the manual valve detent lever assembly exactly ???

can't make sense of the picture... Sorry not the most mechanically inclined.
mrmarsh68 is offline  
post #4 of 13 (permalink) Old 10-15-09, 07:31 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: Transmission Range Sensor ( help !!! )

Just make sure the lever is in neutral. That's all you need to do and I don't know about your sensor, if it's already in neutral or not. That's what the tool is for.
Bert is offline  
post #5 of 13 (permalink) Old 10-16-09, 05:14 AM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 3
Re: Transmission Range Sensor ( help !!! )

Thank you sooo much... I am so glad to find a site this helpful
mrmarsh68 is offline  
post #6 of 13 (permalink) Old 04-07-10, 10:59 AM
Registered User
 
Join Date: Mar 2010
Posts: 4
Re: Transmission Range Sensor ( help !!! )

So where exactly is the Transismission range sensor (TRS) located. I have a '97 V6 Contour, how do I access it to replace.

OK, I found the sensor under the coolant hoses, near the left side of the battery (if standing in front of your car looking at the engine). The part look very different from what I have.

Original looks steel - new one is plastic; little different shape too. I double checked the part number (SW6274 - in Canada) with Ford, they say I may need a wire adapter to connected it. Has anyone used this part and got it to work, without a wire adapter - do I need it ?

I like to do this asap. Please help. Dale
dalermc42 is offline  
post #7 of 13 (permalink) Old 04-07-10, 02:46 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: Transmission Range Sensor ( help !!! )

I've never seen one different than the plastic ones and all the connectors were the same.

Bert
Bert is offline  
post #8 of 13 (permalink) Old 04-07-10, 04:52 PM
Registered User
 
Join Date: Mar 2010
Posts: 4
Re: Transmission Range Sensor ( help !!! )

Thanks, for your responce. I going to take it apart tomorrow. Hope it connects ok. I need a working car.

Dale.
dalermc42 is offline  
post #9 of 13 (permalink) Old 04-07-10, 05:00 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: Transmission Range Sensor ( help !!! )

You should be able to unplug it and try it in the new one without removing the old one.

Bert
Bert is offline  
post #10 of 13 (permalink) Old 04-09-10, 07:55 AM
Registered User
 
Join Date: Mar 2010
Posts: 4
Re: Transmission Range Sensor ( help !!! )

Quote:
Originally Posted by rtg143 View Post
You should be able to unplug it and try it in the new one without removing the old one.
That would be wonderful, if I could get my hands in there. the connector is buried under the rad hoses (2.5 V6 engine - no room at all).

Could not work on it, was raining all day yesterday. I guessing I have to drain the rad before I take it the hoses apart just to get at the Transmission Range Sensor, but the connector looks the same.
dalermc42 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome