Turn signal shorting thru starter - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Mercury Cougar Forum Forum for discussion of the Mercury Cougar.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-17-13, 01:41 PM Thread Starter
Registered User
 
Join Date: Nov 2010
Posts: 2
Turn signal shorting thru starter

I have a strange thing happening. My turn signals are shorting out thru the starter. I would like to know if they share a circuit somewhere in the harness. Here is what happens the turn signal has blown a few fuses while trying to run this down but when i have the engine running and try and install the fuse for turn signals the start engages. I have no clue on this one. Replaced the turn signal switch and they worked for a week and then the same thing. does the start circuit run thru this switch ?

Thanks in advance
Don
dmack31 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-17-13, 07:01 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,283
Re: Turn signal shorting thru starter

There's nothing close to a connection between them. There must be some wires shorted some way. Was the car in a wreck?

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome