Vibation - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Mercury Cougar Forum Forum for discussion of the Mercury Cougar.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-26-04, 12:33 PM Thread Starter
Registered User
Join Date: Feb 2004
Posts: 4

I have a 1984 mercury cougar.
In 1990 I put a 1984 mustang engine 50 HO in.
The car ran great.
Now in 2004 I got a 1980 302 all rebuilt and done that was in a bronco and put it in the cougar and it runs great but has a vibation like flywheel!
Are they bal diffrent the the HO.
I used the my flywheel that came off the Ho
It has a c5 trans!! Woody
woosha00 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 03-18-04, 04:49 PM
aka Moby
Rustyfords's Avatar
Join Date: Jul 2003
Location: South Africa
Age: 52
Posts: 127
Re: Vibation

Anyone know the answer to this, only thing I can think of is if the bronco had a different tranny and you are still using the old tranny.
Rustyfords is offline  
post #3 of 3 (permalink) Old 04-04-04, 03:27 PM
***** Idiot....
LunaticSVT's Avatar
Join Date: Feb 2001
Location: The Sticks of Central TX
Posts: 10,560
Re: Vibation

May want to direct your question in the Tech forums. More people can help you out there.
LunaticSVT is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome