The windshield washer fluid pump is not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Mercury Cougar Forum Forum for discussion of the Mercury Cougar.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-05-11, 08:54 AM Thread Starter
Registered User
 
Join Date: Oct 2010
Posts: 12
The windshield washer fluid pump is not working

I own a 2000 Mercury Cougar V6, The windshield washer fluid pump is not working, I would like to check the fuse but am not sure which one it is. Can anyone tell me which on it is please?

Thank you very much!

cougar88 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-05-11, 09:52 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,341
Re: The windshield washer fluid pump is not working

Fuse 20 under the dash controls the wiper and washer. Here's where you can see the diagram. | Repair Guides | Wipers & Washers (2000) | Wipers & Washers (2000) | AutoZone.com

Bert
Bert is offline  
post #3 of 4 (permalink) Old 01-06-11, 12:48 PM Thread Starter
Registered User
 
Join Date: Oct 2010
Posts: 12
Re: The windshield washer fluid pump is not working

Thank you Sir, you are the best!
cougar88 is offline  
post #4 of 4 (permalink) Old 03-01-11, 04:29 AM
Registered User
 
Join Date: Jan 2011
Location: Wanaka, NZ
Posts: 49
Re: The windshield washer fluid pump is not working

rat eat through your wire / line?
MSull788 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Mercury Cougar Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome