Guages Dont work - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford SVT Vehicles | SVO Vehicles Forum for discussion of all Ford SVT Vehicles, such as: Ford F150 Lightning SVT, Ford Cobra SVT, Ford Focus SVT, Ford Contour SVT and previous SVO vehicles as well.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-16-07, 06:30 PM Thread Starter
Registered User
 
Join Date: May 2007
Posts: 3
Guages Dont work

A couple weeks back my guages started acting up and now they dont work at all can anyone help me please
sillystang is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-16-07, 06:36 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,737
Re: Guages Dont work

More info might help
thefonz is offline  
post #3 of 3 (permalink) Old 05-16-07, 07:24 PM Thread Starter
Registered User
 
Join Date: May 2007
Posts: 3
Re: Guages Dont work

well what info may you need?

my fuel,tach,speedo,battery etc dont work when it first started happening it would just take a bit for the guages to kick on then theyd be ok but now they dont work at all
sillystang is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford SVT Vehicles | SVO Vehicles
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome