Help me fix my cruise and radio!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Audio And Security
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-23-2004, 21:23   #1 (permalink)
Mondeo Obsessed
 
docjames's Avatar
 
Join Date: Dec 2003
Location: Melbourne, Vic
Posts: 89
Help me fix my cruise and radio!!

Hi all,

Thanks in advance for helping me fix my radio and cruise control.!

I have the ST24 model of the 2000 Mondeo. The only non-standard electrical item is cruise, and the radio problem was happening before the cruise was installed. The car has an external aerial (not in the glass like BA falcons).

Ever since i've had the car, the radio crackles on AM only. FM reception is perfect.

If i press / tap (fairly firmly) onto the bottom left of the radio console, it usually stops. Also, occasionally tapping the brakes (just enoguh to put the light on, not to actually slow the car) will stop it happening.

Any ideas? Loose wire? How hard is it to fix?


Also, the cruise will often turn on but not 'arm' (set or resume speed) unless the brakes have been touched. It worked perfectly for about 100km then died. I had it professionally installed, but unfoprtunately it broke while i was away for work, and got back to town after the warranty expired. Now they want to charge me to look for the cruise fault. Needless to say, i wont be recommending them to anyone......

Thanks in advance.

James
__________________
2005 Velocity XR6T is here .........
docjames is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2004, 21:48   #2 (permalink)
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 43
Posts: 3,838
Re: Help me fix my cruise and radio!!

Sounds like an earthing problem, increase the size of the wire from the negative terminal to the body and see if that helps.
__________________
I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline   Reply With Quote
Old 02-28-2004, 19:39   #3 (permalink)
Mondeo Obsessed
 
docjames's Avatar
 
Join Date: Dec 2003
Location: Melbourne, Vic
Posts: 89
Re: Help me fix my cruise and radio!!

Quote:
Originally Posted by Dellboy999
Sounds like an earthing problem, increase the size of the wire from the negative terminal to the body and see if that helps.

Thanks Dellboy , I'll give it a go and let you know!!! Will this (hopefully) work for both problems?
__________________
2005 Velocity XR6T is here .........
docjames is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Audio And Security



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:58.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.