Help! Sirius SAT radio upgrade kit problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-19-05, 12:04 PM Thread Starter
Registered User
 
Join Date: Nov 2005
Posts: 1
Help! Sirius SAT radio upgrade kit problem

Hey there.......any help would be appreciated:

What I have: '06 Escape with Audiophile system - 6 disc in dash CD changer with 7 speakers (inc. sub), satellite capable

What I am trying to do: Install Ford/Visteon satellite radio upgrade kit, which consists of a roof mounted antenna, downlink processor module, and wiring harness to connect head unit to the satellite module.

Problem - installed per instructions, turn on ignition to power and hear a loud pop through the sub. Start car and lots of ignition noise through speakers. Rev engine and noise frequency changes. Hit brake pedal and pop heard through speakers.

Attempted fix - ran a ground wire from downlink module (mounted under passenger side front seat), to door frame hinges, but no change. Removed wiring harness from under door sill trim and kick panel and from under dash. Pulled head unit from dash and disconnected satellite wiring harness. Hooked head unit back up to original radio harness and checked for noise. Everything back to normal. Hooked up satellite radio harness to head unit and downlink processor and left wiring in the center of the vehicle (where front passenger seat should mount). Turned ignition to "on" and got the same pop from sub. Did not start car but turned on radio to FM station, and have noise through the sub......kind of a rythmic / pulsing noise.

I am tempted to take this kit back and put on my dash mounted Sportster from Sirius. I really wanted to clean things up and use the in dash controls.

Any help???? Going to call Visteon on Monday to see if they can offer any suggestions.

Thanks in advance,
Jim

Rubicon is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-15-05, 09:39 AM
Registered User
 
Join Date: Dec 2005
Posts: 1
Re: Help! Sirius SAT radio upgrade kit problem

Have you had any help on this issue. I am about to start down the same path you have started
Mike Fulkerson
Carlsbad, NM
mfulker@caverns.com

Quote:
Originally Posted by Rubicon
Hey there.......any help would be appreciated:

What I have: '06 Escape with Audiophile system - 6 disc in dash CD changer with 7 speakers (inc. sub), satellite capable

What I am trying to do: Install Ford/Visteon satellite radio upgrade kit, which consists of a roof mounted antenna, downlink processor module, and wiring harness to connect head unit to the satellite module.

Problem - installed per instructions, turn on ignition to power and hear a loud pop through the sub. Start car and lots of ignition noise through speakers. Rev engine and noise frequency changes. Hit brake pedal and pop heard through speakers.

Attempted fix - ran a ground wire from downlink module (mounted under passenger side front seat), to door frame hinges, but no change. Removed wiring harness from under door sill trim and kick panel and from under dash. Pulled head unit from dash and disconnected satellite wiring harness. Hooked head unit back up to original radio harness and checked for noise. Everything back to normal. Hooked up satellite radio harness to head unit and downlink processor and left wiring in the center of the vehicle (where front passenger seat should mount). Turned ignition to "on" and got the same pop from sub. Did not start car but turned on radio to FM station, and have noise through the sub......kind of a rythmic / pulsing noise.

I am tempted to take this kit back and put on my dash mounted Sportster from Sirius. I really wanted to clean things up and use the in dash controls.

Any help???? Going to call Visteon on Monday to see if they can offer any suggestions.

Thanks in advance,
Jim
fulkersonm is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Audio And Security
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome