Premium Sound Radio Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Audio And Security
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-31-2005, 08:01   #1 (permalink)
Cleabert
Guest
 
Posts: n/a
Premium Sound Radio Problem

I am having a problem with the Premium Sound Radio in my 1994 Mustang GT
Coupe.

All the controls on the radio operate perfectly. The problem is the radio
can barely be heard through all four speakers. I have checked fuses,
checked the antenna, switched out the radio, switched out the amplifier,
tested the speakers, and still have not found the problem. Can anyone
shed some light on the possible problem.

  Reply With Quote
Sponsored Links
Advertisement
 
Old 07-31-2005, 12:01   #2 (permalink)
Ashton Crusher
Guest
 
Posts: n/a
Re: Premium Sound Radio Problem

On Sun, 31 Jul 2005 10:31:44 -0400, "Cleabert" <dcbjerke@juno.com>
wrote:

>I am having a problem with the Premium Sound Radio in my 1994 Mustang GT
>Coupe.
>
>All the controls on the radio operate perfectly. The problem is the radio
>can barely be heard through all four speakers. I have checked fuses,
>checked the antenna, switched out the radio, switched out the amplifier,
>tested the speakers, and still have not found the problem. Can anyone
>shed some light on the possible problem.


Have you verified the amp is getting power?
  Reply With Quote
Old 08-03-2005, 04:01   #3 (permalink)
Gearhead-FMC
Guest
 
Posts: n/a
Re: Premium Sound Radio Problem

Sounds like one of your speaker wires is grounded to the chassis...........

--
Gearhead-FMC
95" '03 FLHTCUI
"Cleabert" <dcbjerke@juno.com> wrote in message
news:5d7f367537ce003e9714d9e0ea696d60@localhost.talkaboutautos.com...
>I am having a problem with the Premium Sound Radio in my 1994 Mustang GT
> Coupe.
>
> All the controls on the radio operate perfectly. The problem is the radio
> can barely be heard through all four speakers. I have checked fuses,
> checked the antenna, switched out the radio, switched out the amplifier,
> tested the speakers, and still have not found the problem. Can anyone
> shed some light on the possible problem.
>



  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Audio And Security



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:29.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.