Response 6.5" splits blow!!!!!!!!!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Audio And Security
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-27-2003, 01:43   #1 (permalink)
Registered User
 
1LOWEA's Avatar
 
Join Date: Oct 2002
Location: Melbourne
Posts: 434
Response 6.5" splits blow!!!!!!!!!!!

Hi everyone

last monday, i purchased 2 sets of response splits. I got them installed and it was all running smoot for 24 hours, next morning 1 of the tweeters was not working. I took it back to jaycar and they said it must of been faulty. WELLLLLLLLL it is now sunday, and 3 tweeters are dead, they are not working at all. I checked everything, wiring, componet boxes etc etc. Nothing, i got my mate from JB to come round and have a look, we trippled checked the wiring on the amp, component deck etc. Nothing. I have now 1 tweeter left, all the woofers are working fine. I am gona take all 4 tweeters back to jaycar and force them to change them for another damm tweeter set. I cannot belive how f*kN crap these tweeters are. I am so pissed of at response how can you make such cheap shit, even sound 4 splits dont fkup as bad. If these idoits dont swap my tweets, i am gona rip out the whole system and refund it because it is a peace of shit. NEVER BUY RESPONSE SPLITS!!!!!!!. I have 4 spare kicker tweets running atm and have been running them for 2 days. They have not stuffed up at all. Seriouslt this brand sucks, what a joke.
__________________
1996 EF Fairmont
17" EL Tickford Wheels
2.5" Redback Exhuast
GL PRO SOUND
www.glprosound.com.au
1LOWEA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-27-2003, 04:45   #2 (permalink)
Mechanical Dumbass
 
FUNKY_FALCON's Avatar
 
Join Date: Apr 2003
Location: ACT
Age: 28
Posts: 228
IMO response is one of the best brands value for money and quality wise, i have been running 6" 60rms response speakers off a a shitty amp for a year now and they have been faultless. they sound and go SO much louder then all my mates speakers of the same value....sounds like you got a rooted batch there though, happens with every brand, unlucky
__________________
http://howefamily.ath.cx/chris/
FUNKY_FALCON is offline   Reply With Quote
Old 07-27-2003, 05:11   #3 (permalink)
Registered User
 
1LOWEA's Avatar
 
Join Date: Oct 2002
Location: Melbourne
Posts: 434
Re: Response 6.5" splits blow!!!!!!!!!!!

Im gona take them back to jaycar, and swap the tweets, This is just a joke i cant belive it. If the next batch play up response will be on the black list for me.
__________________
1996 EF Fairmont
17" EL Tickford Wheels
2.5" Redback Exhuast
GL PRO SOUND
www.glprosound.com.au
1LOWEA is offline   Reply With Quote
Old 07-27-2003, 05:48   #4 (permalink)
"Steve has a car?"
 
Rmyers's Avatar
 
Join Date: Jun 2002
Location: Melbourne
Age: 31
Posts: 2,207
Re: Response 6.5" splits blow!!!!!!!!!!!

Just bite the bullet and get some Rainbow reference series splits, at a mere $14,000,you shouldn't have a problem wioth them haha

nah but seriously, did they just stop working or did they actually snap, crackle and pop? Tweeters shouldn't just stop working, the tweets you got must be faulty when you got them, this is the first i've heard of this happen....
__________________
Rmyers is offline   Reply With Quote
Old 07-27-2003, 06:08   #5 (permalink)
Hanging Around
 
9psi EB's Avatar
 
Join Date: Feb 2002
Location: Perth
Age: 35
Posts: 1,209
Re: Response 6.5" splits blow!!!!!!!!!!!

Sounds to me the crossovers are incorrectly connected, not hi-passing for the tweeters.

Recheck all wiring from the amp through the crossover to the tweeter, if they are not crossed over correctly, they will blow straight away.

Connect a normal speaker (one of your old ones) to the tweeter wires, and turn the volume up, the cone should NOT move, and you should only hear treble, and no mid / bass.

It could be possible that the kicker ones have built in capacitors, therefore not blowing like the response ones did.
__________________
Event's Photo Gallery: gallery.mechanicalforums.com

Last edited by 9psi EB; 07-27-2003 at 06:11.
9psi EB is offline   Reply With Quote
Old 07-27-2003, 06:57   #6 (permalink)
Teh Pimp
 
One Ford Drone's Avatar
 
Join Date: Jul 2003
Location: Kurmond, NSW
Age: 28
Posts: 311
Re: Response 6.5" splits blow!!!!!!!!!!!

lol, Response (Jay Car) have excellent amps as they are good value for money and pump out quite a decent signal... But yes, it is a common rule that you actually have to buy a branded speaker to get some decent quality.
One Ford Drone is offline   Reply With Quote
Old 07-27-2003, 07:06   #7 (permalink)
Hanging Around
 
9psi EB's Avatar
 
Join Date: Feb 2002
Location: Perth
Age: 35
Posts: 1,209
Re: Response 6.5" splits blow!!!!!!!!!!!

not necessarily...

sony speakers sound like
imo anyway
__________________
Event's Photo Gallery: gallery.mechanicalforums.com
9psi EB is offline   Reply With Quote
Old 07-27-2003, 08:54   #8 (permalink)
Registered User
 
1LOWEA's Avatar
 
Join Date: Oct 2002
Location: Melbourne
Posts: 434
Re: Response 6.5" splits blow!!!!!!!!!!!

They never crackled or anything, they 1 by one they stoped working, lmao i was like ok....... I have all 4 channels on the amp set to "HP". Its funny that one tweeter still works and 3 dont. As someone said i might have got a bad batch.
__________________
1996 EF Fairmont
17" EL Tickford Wheels
2.5" Redback Exhuast
GL PRO SOUND
www.glprosound.com.au

Last edited by 1LOWEA; 07-27-2003 at 09:10.
1LOWEA is offline   Reply With Quote
Old 07-27-2003, 11:01   #9 (permalink)
"Steve has a car?"
 
Rmyers's Avatar
 
Join Date: Jun 2002
Location: Melbourne
Age: 31
Posts: 2,207
Re: Response 6.5

Quote:
Originally Posted by 9psi EB
Sounds to me the crossovers are incorrectly connected, not hi-passing for the tweeters.

Recheck all wiring from the amp through the crossover to the tweeter, if they are not crossed over correctly, they will blow straight away.

Connect a normal speaker (one of your old ones) to the tweeter wires, and turn the volume up, the cone should NOT move, and you should only hear treble, and no mid / bass.

It could be possible that the kicker ones have built in capacitors, therefore not blowing like the response ones did.
Never thought of this possibility! You may very well have them set up incorrectly to begin with. Check the settings and wiring at the crossover....
__________________
Rmyers is offline   Reply With Quote
Old 07-27-2003, 23:05   #10 (permalink)
Teh Pimp
 
One Ford Drone's Avatar
 
Join Date: Jul 2003
Location: Kurmond, NSW
Age: 28
Posts: 311
Re: Response 6.5

Quote:
Originally Posted by 9psi EB
not necessarily...

sony speakers sound like
imo anyway
OMFG you are so right! How the hell did I forget to mention them... Sony are POS! Stay away...
__________________
GOOD ON YOU LATER!
One Ford Drone is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Audio And Security



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing 6.5" splits in the front door YOOT General Tech 27 08-15-2002 03:58
Jaycar Response Splits in EF - Sensitivity? jr_4226 General Tech 9 07-28-2002 23:35

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:37.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.