1995 E-250 4.9 electrical issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-07-09, 02:19 PM Thread Starter
Registered User
Join Date: Mar 2009
Posts: 3
1995 E-250 4.9 electrical issues

Hi, I own a 95 e250. Pulled the into the gas station to get gas. Shut van off. Paid/pumped gas. Then I went to leave and it acted like the battery was dead. Swapped batteries no diferance. Got a jump, yay it starts. Go to a buddies, shut it off and tried to start again...nothing. so my battery meter shows not enough power, about half of normal. Been troubleshooting for days.. figured maybe you guys could help. List of what Ive done. Switched the Solenoid. Cleaned the wires going to starter. Please help. Thanks.
dirtjumperrobh is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome