87 xf problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-29-2005, 07:33 Thread Starter
Registered User
Join Date: Jan 2005
Posts: 1
confused 87 xf problem

hey all this is my first post on this forum, i own an 87 xf sedan s pac, my uncles old car so its been looked after pretty well, anyway, a while ago it started blowing fuses, namely the 10amp fuse for my indicators and my digital dash.... the battery light also comes on when its blows.... the other one that blows is 15 amp fuse for the backlight for my speedo and my rear night lights....

this is the first problem i've had with my baby, it wasnt too bad but now i cant use my left indicator because it makes the fuse blow, and i cant turn on my headlights at night because my rear lights die.... i know i'm probably going to have to take it to an auto electrician..... can anyone give me any tips? how much its probably going to be? any help would be greatly appreciated...
cerbera is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-30-2005, 03:12
Who wants more than 80kw?
Join Date: Jan 2005
Posts: 95
Re: 87 xf problem

This is a really long shot but:

I had a similar thing with my XD. I towed a trailer and the electrics shorted out in the trailer plug, and hence in the car.

Rather than blow the fuse it actually blew part of the hazard switch up and everytime I tried to use the indicators it would blow the fuse.

If it has a trailer plug, I would check the electrics in that first. That is the only place that the indicators, brake lights and number plate illumination meet that i can think of on top of my head. (Not sure about the dash tho)

Hopefully it is of some help, other than that it will be $$$ at the auto electrican, since those digital dashes are complicated...
81foXDwagon is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech

Quick Reply

Register Now

In order to be able to post messages on the Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
'87 Crown Vic cold weather starting problem taco_90 Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 0 08-24-2004 13:56
XF Falcon - running problem Smithy General Tech 8 10-22-2003 23:03
warm starting problem with 87 Ranger havns3 Ford Ranger Forum 5 04-07-2003 09:43
Engine troubles in XF MK XR8 Inline 6 Tech 2 01-30-2002 06:16

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome