EA 3.9 motor randomly cutting out while driving - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-01-05, 11:42 PM Thread Starter
Registered User
Join Date: Jul 2002
Location: South of Sydney, NSW
Posts: 19
EA 3.9 motor randomly cutting out while driving


Had a quick search but could not find a post similar. My EA 3.9 MPFI keeps cutting out at random times.

For example driving along the freeway at 110kms and all of a sudden the tacho registers 0 rpms then after about a second or two it starts up again and runs fine. It has also happened comming out of a round about at slow speed and also happened whilst ideling. It is happening at random, i.e. it is not just happening as I am comming out of a corner or just getting on the accelarator.

Today it decided to play up properly and for a while it did not want to idle at all after running the car at freeway conditions for about 30mins. For about 10 mins i had trouble keeping the engine running. Finally by the time I reached home the car was idleing properly and all was fine, wierd.

I have checked all electrical connections in the engine bay and under the car. After that thinking that it was a fuel quality problem ( it seemed like that anyway) I removed the old fuel filter and checked for any water or garbage (all was fine), replaced with a new one and also flushed the existing fuel out of the injector rail via the fuel pressure regulator and no water in there either and the problem is still happening.

I am guessing that it might be a sensor problem.

Any ideas would be great as I am a but sick of turning into a corner to realise that I have no power steering or engine power at all.

Thanks in advance
Styles is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
My EA is like driving a boat!! youngNstupid E-Series Falcons 3 12-22-04 11:55 PM
ECU for BBM into 89 EA 3.9 5spd Manual?? samsonEB E-Series Falcons 1 10-11-04 05:05 PM
EA 3.9 MPFI into XD??? AU2FalconS Inline 6 Tech 4 07-07-04 01:54 PM
EA Engine, Trans and other bits Sundeep Trans | Driveline 1 05-26-04 06:28 PM
MATT HELMS: Poll shows top slowpokes are driving a Buick next is the Marquis GMACK24 Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 0 02-27-04 08:32 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome