EB I6 running very rich...help! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-17-02, 05:35 AM Thread Starter
8 cylinder symphony
 
b-juggles's Avatar
 
Join Date: Mar 2002
Location: Sydney
Posts: 1,348
EB I6 running very rich...help!

Hey all,

my eb his running really really rich - running so rich in fact the oil starts to turn darkish after about 1000kms - my old ea never used to do this.


What are the possible causes of this? What sensors etc should i checkout to see if they are not working properly?

Thanks,

Brendan

b-juggles is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-18-02, 01:53 AM
Yeah .... I am here
 
XR8fella's Avatar
 
Join Date: Apr 2002
Location: Coffs Harbour NSW
Age: 35
Posts: 751
had same prob on ED I6.
told to check oxygen sensor (on exhaust manifold) and MAP sensor (Firewall above fuel rail) and coolant sensor (thermostat housing), so i replaced all in frustration, turned out it was the wiring from MAP sensor to ECU. but try those sensors !! if the car has been running rich for a while to Oxygen sensor will be stuffed anyhow !

His :
Black AU II XR8 Manual Ute
Hers :
XR8fella is offline  
post #3 of 5 (permalink) Old 08-18-02, 02:10 AM Thread Starter
8 cylinder symphony
 
b-juggles's Avatar
 
Join Date: Mar 2002
Location: Sydney
Posts: 1,348
ok cool, how do i test them?

should there be a certain voltage running through them or something?

thanks
b-juggles is offline  
post #4 of 5 (permalink) Old 08-18-02, 05:41 AM
Two SC 61's = trouble
 
ebxr8240's Avatar
 
Join Date: Jul 2001
Location: Penrith,nswAus/Morrinville.NZ
Age: 62
Posts: 6,360
Also check vacuum line to map senser for leaks..

Don't be afraid to try something new. Remember, amateurs built the Ark...Professionals built the Titanic!
.
Tuned & maintained by "Peppertree Perfmormance". Dart block, Scat 4340 steel crank, Custom C.P pistons.Oliver rods.. Mal Wood twin plate clutch.. Twin SC61/2's,482 rwkw/ 645 rwhp..
Passengers, myocardial infarction material..
R.I.P Possum...
ebxr8240 is offline  
post #5 of 5 (permalink) Old 08-18-02, 05:16 PM
Registered User
 
Join Date: Jan 2002
Location: Brisbane
Posts: 231
If you don't have any luck with these, try the fuel pressure regulator (on the back end of the fuel rail). Cannect a gauge into the line from the tank, and it should read around 200-250kPa with the engine running.
rally is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ea cfi running rich ? rabbi General Tech 3 05-25-03 10:26 PM
EB I6 to V8 Crossmember BlownV8 Inline 6 Tech 7 05-14-03 01:29 PM
Running Rich THEONE General Tech 6 05-05-03 04:17 AM
EB I6 power figures Falchoon Inline 6 Tech 6 03-17-02 03:08 AM
running rich ncspeed Ford Probe Forum | Mazda MX6 Forum 25 12-25-01 07:07 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome