EB lost power and changing gear too early... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 11-29-04, 03:09 AM Thread Starter
what u lookin at
 
needturbo6's Avatar
 
Join Date: Sep 2004
Location: WA
Age: 32
Posts: 777
EB lost power and changing gear too early...

the car: EB2 4sp auto MPi, new leads, new iridium plugs, dizzy cap/rotor button,

problem: feels like its lost a heap of power plus its changing gear full throttle at 3000rpm! in ecom. and 4000rpm in power!?

usually it changes at about 4500rpm in ecom and ~5000 in "power" mode.

any ideas what this could be (TPS?) or anyone had similar problems?

needturbo6 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 11-29-04, 05:18 AM
Registered User
 
madmelon's Avatar
 
Join Date: Apr 2003
Location: Shire :D
Age: 31
Posts: 439
Re: EB lost power and changing gear too early...

mayb dizzy was put on hella redtarded, thats why u have no power. That don't explain early gear changes tho...hmmm. Maybe the whole lot is due to a computer issue. I know EA's were/are notorious for computer issues...and its EEC4, same as EB, EB2, ED falcons...perhaps this could be it?
...just throwing round ideas...i don't really know that much about these issues...

1987 Jaguar Sovereign - Metallic Green
3.6L DOHC 24 Valve
140KW@4750rpm
307Nm@3750rpm (Flywheel)
madmelon is offline  
post #3 of 15 (permalink) Old 11-29-04, 05:27 AM Thread Starter
what u lookin at
 
needturbo6's Avatar
 
Join Date: Sep 2004
Location: WA
Age: 32
Posts: 777
Re: EB lost power and changing gear too early...

i forgot to state that it hasnt just happened after anything was changed, it was running great 4 a bit then only recently noticed the problem. i did change the plugs to iridiums about 3 days ago but that cant be it surely, then went for a long drive (bout 1 1/2hrs there and back) and it doesnt wanna get goin anymore, its such a slug! i might get it checked for any fault codes.

the car did have to get jump started while down there. no surge protector either. could be ecu, hopefully not....
needturbo6 is offline  
post #4 of 15 (permalink) Old 11-29-04, 12:45 PM
96 EF Futura
 
SiX_iN_a_RoW's Avatar
 
Join Date: Aug 2002
Location: Now Residing in Brisbane
Age: 33
Posts: 2,494
Re: EB lost power and changing gear too early...

Could be alot of things, id test the TPS and also check your throttle cable.

Lets go find that Hotdog tree I planted

Lowered EF Futura
Black Steelies ( too cheap to buy proper mags )
SiX_iN_a_RoW is offline  
post #5 of 15 (permalink) Old 12-01-04, 02:18 AM Thread Starter
what u lookin at
 
needturbo6's Avatar
 
Join Date: Sep 2004
Location: WA
Age: 32
Posts: 777
Re: EB lost power and changing gear too early...

well i found the problem, as above, the throttle isnt opening fully, its prob only opening less than 2/3rds of the way. just about to investigate further....
needturbo6 is offline  
post #6 of 15 (permalink) Old 12-01-04, 02:44 AM Thread Starter
what u lookin at
 
needturbo6's Avatar
 
Join Date: Sep 2004
Location: WA
Age: 32
Posts: 777
Re: EB lost power and changing gear too early...

anyone got any ideas? stretched cable?
at the pedal hits the stop, its a hard one to figure out
needturbo6 is offline  
post #7 of 15 (permalink) Old 12-01-04, 02:59 AM
96 EF Futura
 
SiX_iN_a_RoW's Avatar
 
Join Date: Aug 2002
Location: Now Residing in Brisbane
Age: 33
Posts: 2,494
Re: EB lost power and changing gear too early...

have someone jump in the car and hold the pedal to the floor. Have a look at the throttle lever, check to see if its opening fully. You may be able to adjust it ( cant remember ) if not replace the cable if theres no other obvious faults

Lets go find that Hotdog tree I planted

Lowered EF Futura
Black Steelies ( too cheap to buy proper mags )
SiX_iN_a_RoW is offline  
post #8 of 15 (permalink) Old 12-01-04, 03:05 AM Thread Starter
what u lookin at
 
needturbo6's Avatar
 
Join Date: Sep 2004
Location: WA
Age: 32
Posts: 777
Re: EB lost power and changing gear too early...

yeh its not opening fully, ill check to see if theres an adjustment, only thing is theres a lot to adjust- about 1/3 of the opening. but ill go check it out now.
needturbo6 is offline  
post #9 of 15 (permalink) Old 12-01-04, 03:11 AM Thread Starter
what u lookin at
 
needturbo6's Avatar
 
Join Date: Sep 2004
Location: WA
Age: 32
Posts: 777
Re: EB lost power and changing gear too early...

i can only see one adjustment and it doesnt look like it has enough thread to adjust it right up. i might be up for a new cable...
needturbo6 is offline  
post #10 of 15 (permalink) Old 12-01-04, 03:18 AM
96 EF Futura
 
SiX_iN_a_RoW's Avatar
 
Join Date: Aug 2002
Location: Now Residing in Brisbane
Age: 33
Posts: 2,494
Re: EB lost power and changing gear too early...

yeah it happens....my EA did it suddenly too. man the power increase was huge when i got a new cable, Best bang for ya buck performance mod of all!!

Lets go find that Hotdog tree I planted

Lowered EF Futura
Black Steelies ( too cheap to buy proper mags )
SiX_iN_a_RoW is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing the Exhaust Gas Oxygen sensor to give better ECONOMY! Con Exhaust 22 10-05-04 11:32 PM
Eu:mazda6 Mps: The Ultimate Zoom-zoom Saloon Stacy94PGT Mazda Forum 0 09-23-04 08:00 AM
Here we go again. Supercar Scare!!! EL2 XR8 The Pub 59 08-11-04 10:11 PM
power steering from non power steering? davway General Tech 9 04-26-04 03:18 AM
EF power flat spot, what the...? MightyEFGhia Inline 6 Tech 24 07-30-03 03:03 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome