EFXR6 wagon fitted extractors and lost power - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-25-2004, 20:38   #1 (permalink)
Registered User
 
bennyboy's Avatar
 
Join Date: Mar 2004
Location: Adelaide
Posts: 20
EFXR6 wagon fitted extractors and lost power

EFXR6 wagon one of of those rare beasts. I recently put extractors and 2 1/2 system on it. When I drove out of the shop it felt sluggish. It now uses a bit more fuel also. After allowing some time (kms) for the computer to adjust to the new airflow I went back to the exhaust shop and they told me this cannot be possible. It seems to have popped up a few times in these forums. I have been to an auto electrician and no errors were found in the system. The oxygen sensor seems the most likely culprit. I have disconnected it and driven around the block there was no evident change. How else can I check the oxygen sensor, or any other ideas as to the problem?
bennyboy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-25-2004, 20:58   #2 (permalink)
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 43
Posts: 3,838
Re: EFXR6 wagon fitted extractors and lost power

Disconnect the battery for about 1/2 hour, then it will re-learn but hopefully increase power, drive like a granny, drive full throttle, vary it up for about 15 mins at least.

It may take 5 mins for idle to sort itself out.

Jason
__________________
I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline   Reply With Quote
Old 03-25-2004, 22:32   #3 (permalink)
Registered User
 
Join Date: May 2003
Location: Townsville NQ
Age: 32
Posts: 797
Re: EFXR6 wagon fitted extractors and lost power

whqat delboy said
__________________
EvilChief is offline   Reply With Quote
Old 03-26-2004, 03:00   #4 (permalink)
Registered User
 
xr6wgn's Avatar
 
Join Date: Feb 2001
Location: Adelaide, SA, Australia
Posts: 542
Re: EFXR6 wagon fitted extractors and lost power

Quote:
Originally Posted by bennyboy
EFXR6 wagon one of of those rare beasts. I recently put extractors and 2 1/2 system on it.
Another XR6 Station Wagon! - they are obviously not that rare in Adelaide He He. Although I also suspect it's probably your computer that needs a reset, when they did your Extractors/exhaust did they also look at your cat? (it might be blocked) Can I ask who did the extractors and what brand?? (I already have an exhaust done - I'm looking for extractors)

Oh Welcome to the Forums BennyBoy

Paul B
XR6WGN
__________________
476 EF XR6 Wagons - 198 were Manual
Member Tickford / FPV Club - SA
xr6wgn is offline   Reply With Quote
Old 03-26-2004, 05:13   #5 (permalink)
Experimental Racer#6
 
TIKFD6's Avatar
 
Join Date: Nov 2000
Location: Wodonga Vic
Age: 41
Posts: 8,204
Re: EFXR6 wagon fitted extractors and lost power

Mate what brand of extractors are they?
TIKFD6 is offline   Reply With Quote
Old 03-28-2004, 02:21   #6 (permalink)
Registered User
 
bennyboy's Avatar
 
Join Date: Mar 2004
Location: Adelaide
Posts: 20
Re: EFXR6 wagon fitted extractors and lost power

The extractors are Advanced Headers. The manager used to be one of the R & D guys for Genie and he copied them. The exhaust guys at discount exhaust on Port rd checked the cat when they did the system and said it was alright.
bennyboy is offline   Reply With Quote
Old 03-28-2004, 02:48   #7 (permalink)
Yes, fords still kick
 
MickyB's Avatar
 
Join Date: Jul 2002
Location: Frankston
Age: 32
Posts: 668
Re: EFXR6 wagon fitted extractors and lost power

Wonder how Genie feel about that. It does seem very unusual, when I had Genie extractors on my old EB 4 litre it felt better not worse. And as it is supposedly breathing better fuel economy should have improved. Can you hear any leaks around the gasket or where they have welded them up to the cat?
__________________
Black EB S-XR6 5 Speed Lukey Exhaust Lowered AU2 Tickford Wheels
Alpine CDA-7892E,Alpine MRD-M500, Alpine MRV-F303, Alpine Type 'S' 12" Subs x 2, Boston Acoustics RC620 and CX-6
MickyB is offline   Reply With Quote
Old 03-28-2004, 04:42   #8 (permalink)
Experimental Racer#6
 
TIKFD6's Avatar
 
Join Date: Nov 2000
Location: Wodonga Vic
Age: 41
Posts: 8,204
Re: EFXR6 wagon fitted extractors and lost power

I used to have Genies on my ED XR6, when i swapped them to Mock(Hitech), there was a noticable improvement.

Genies have big primaries, the air just casually comes out.
TIKFD6 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble!!! Help. Put stage 3 crow cam in my EA and lost power!!!! Grant Porter Inline 6 Tech 50 06-14-2004 22:37
Ford falcon EL futura, service yesturday.. extractors and exhuast today. lost power [atomic]nexus Australian Falcons 7 01-31-2004 16:55
HELP: Pacemakers fitted --> Lost power !!!! BLACK XR6-VCT Inline 6 Tech 52 01-06-2004 05:05
DYNOED AND STARTING TO SMILE??? lukeyn039 General Tech 26 03-17-2002 18:53

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 13:17.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.