Engine mounts broken - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-26-04, 11:35 PM Thread Starter
Ford Member
 
Join Date: Jul 2003
Location: Robina
Age: 33
Posts: 364
Engine mounts broken

Today my left engine mount broke on the xf after doing a hillstart. After i crapped myself becuase of the weird vibrations i located the prob and pickup a new one from super cheap.

Undone all the bolts BUT one i cant get to at the front inside the mount! I cant see how anyone could get to it unless the motor was lifted up really high.

Does anyone know how to do it or has done it before?

Ive just noticed the right side has had-it too! Prob because of the other one broken :(

Pete

fordmuscle_83 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-27-04, 07:25 AM
Finnaly back
 
Join Date: Jul 2002
Location: WA
Age: 16
Posts: 1,124
Re: Engine mounts broken

Ive done them both when I put my engine in and the tranny mount, but I had it up on a block n tackle, what you prob wanna do is lift your engine up bolt on both your mounts to the engine, lower it, line one side up bolt it in then the same for the other, thats how I did it, and that wasnt to much hassle, although I didnt have the air box or extractors on at the time. also did some on and F100, we used a jack and a piece of wood under the sump, but thats not the safest thing in the world, plus I dont think you can do that on the XF because of the bar that runs under the engine.
hope some of this helps.
Chad_XF is offline  
post #3 of 3 (permalink) Old 01-27-04, 03:40 PM Thread Starter
Ford Member
 
Join Date: Jul 2003
Location: Robina
Age: 33
Posts: 364
Re: Engine mounts broken

The xf manual says to use a block of wood on a jack and lift with the through bolts removed. Im not sure on how high you can go as obviously the tranny and extractor pipes are all still attached. However high you go its still not going to be enough to get at the front mount bolt unless the engine was lifted out like you say Chad, which isnt possible as i dont have the gear.
fordmuscle_83 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Holdens new V6 EED-250 The Pub 52 08-09-03 10:07 PM
Tsb: 2002 Explorer Sport Trac LunaticSVT Ford Escape | C-MAX | Mercury Mariner Forum 0 07-15-03 02:27 PM
EA to AU engine mounts the same? DansEdgli General Tech 4 03-13-03 02:42 AM
A New Boss Born in Australia RPO83 Ford Worldwide News 0 10-16-02 06:12 PM
BA Falcon Engine Reveal RPO83 Ford Worldwide News 0 09-04-02 07:27 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome