Engine mounts broken - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-26-2004, 23:35   #1 (permalink)
Ford Member
 
Join Date: Jul 2003
Location: Robina
Age: 31
Posts: 364
Engine mounts broken

Today my left engine mount broke on the xf after doing a hillstart. After i crapped myself becuase of the weird vibrations i located the prob and pickup a new one from super cheap.

Undone all the bolts BUT one i cant get to at the front inside the mount! I cant see how anyone could get to it unless the motor was lifted up really high.

Does anyone know how to do it or has done it before?

Ive just noticed the right side has had-it too! Prob because of the other one broken :(

Pete
fordmuscle_83 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-27-2004, 07:25   #2 (permalink)
Finnaly back
 
Join Date: Jul 2002
Location: WA
Age: 13
Posts: 1,124
Re: Engine mounts broken

Ive done them both when I put my engine in and the tranny mount, but I had it up on a block n tackle, what you prob wanna do is lift your engine up bolt on both your mounts to the engine, lower it, line one side up bolt it in then the same for the other, thats how I did it, and that wasnt to much hassle, although I didnt have the air box or extractors on at the time. also did some on and F100, we used a jack and a piece of wood under the sump, but thats not the safest thing in the world, plus I dont think you can do that on the XF because of the bar that runs under the engine.
hope some of this helps.
Chad_XF is offline   Reply With Quote
Old 01-27-2004, 15:40   #3 (permalink)
Ford Member
 
Join Date: Jul 2003
Location: Robina
Age: 31
Posts: 364
Re: Engine mounts broken

The xf manual says to use a block of wood on a jack and lift with the through bolts removed. Im not sure on how high you can go as obviously the tranny and extractor pipes are all still attached. However high you go its still not going to be enough to get at the front mount bolt unless the engine was lifted out like you say Chad, which isnt possible as i dont have the gear.
fordmuscle_83 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Holdens new V6 EED-250 The Pub 52 08-09-2003 22:07
Tsb: 2002 Explorer Sport Trac LunaticSVT Ford Escape | C-MAX | Mercury Mariner Forum 0 07-15-2003 14:27
EA to AU engine mounts the same? DansEdgli General Tech 4 03-13-2003 02:42
A New Boss Born in Australia RPO83 Ford Worldwide News 0 10-16-2002 18:12
BA Falcon Engine Reveal RPO83 Ford Worldwide News 0 09-04-2002 07:27

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:09.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.