Engine Run-On in EA MPFI (Converted) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-11-04, 02:09 PM Thread Starter
Vroom vroom
 
spope's Avatar
 
Join Date: Feb 2004
Location: Io
Age: 35
Posts: 233
Engine Run-On in EA MPFI (Converted)

Hi all. I've got a 10/90 EA that has been converted to multi-point. Just recently, I've started getting engine run-on, and it's been getting progressively worse, to the point where this morning I had to let the fuel pump go for 2-3 times to get fuel back into the rail.
Some other info: I think my ISC is buggered, when I'm in gear at idle it sits at around 6-700 rpm, however, when I put it in park after it's been driven, the idle kicks up to around the 1800 rpm mark. It then dips really badly when I put it back in gear.
The other thing is my cat converter is restricting exhaust flow quite badly at the moment, it's stuffed.
So basically, what should I be looking for to stop the run-on? Could the faulty isc be causing it, by still letting air into the manifold after the car has stopped?
Any other ideas? Any help would be appreciated.


EA GL-Ghia pseudo operator
3.9 MPFI converted 4 speed
2.5 inch exhaust
NC Ghia interior (except rear trims)
Fairmont audio (with 4 speakers)
Cruise control
S-pac cluster with white dials
Trip computer and Fairmont interior lighting.
Half wired Ghia BCM.
spope is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-11-04, 10:29 PM
Pimpin the chrome
 
InitialD's Avatar
 
Join Date: Aug 2004
Location: Melbourne
Age: 32
Posts: 771
Re: Engine Run-On in EA MPFI (Converted)

Spope, Im having the EXACT Same probs with my EA CFI! Damn Metallic Blue EA's

1991 Ford Falcon EA 30th Anniversary

EF head | EF XR6 Cam |Pacemaker 3320(?) extractors | Hiflo cat
3:23 | Auto | XH Snorkle | Thermos | 2.5" Mandrel Exhaust
Full NC2 Sportsman Interior inc Dash & Electrics
Custom Clear Tailights and Garnish
Sprint kit | Moffat front bar (soon) | king lows
FTR Chrome Rims | Driving lights | Custom ED Mesh grill
Pioneer of the Clear ED tailights
InitialD is offline  
post #3 of 5 (permalink) Old 11-12-04, 01:29 AM
'90 EA-II Fairmont
 
SileNceR's Avatar
 
Join Date: Aug 2003
Location: Warrnambool, VIC, Aust.
Age: 32
Posts: 572
Re: Engine Run-On in EA MPFI (Converted)

spope make sure the ISC and TB are both attached properly, that could be causing the idle problems perhaps... that and vacuum leaks, check all ur vac hoses

Rosewood EAII Fairmont 02/90. MPFI 3.9L (formerly CFI), 4spd BTR Auto. Skyline geared 3.45g open center 28 spline 4 pinion differential & axles. 2 1/2" Cat Back Exhaust. King Super Low Springs. Sound: Equalization and amplification by Clarion; Head unit by Sony, Front, Rears and Sub by Pioneer. Planned mods - t5, Extractors, Painting Grey Strips and new front and rear bar.
SileNceR is offline  
post #4 of 5 (permalink) Old 11-16-04, 12:00 AM
Veteran Ford Member
 
Join Date: Jan 2003
Location: Melbourne, Australia
Age: 31
Posts: 5,083
Re: Engine Run-On in EA MPFI (Converted)

Timing isn't the major issue here, fuel still getting into the combustion chambers is. Half your injectors must be leaking.
psycho chicken is offline  
post #5 of 5 (permalink) Old 11-17-04, 01:53 AM Thread Starter
Vroom vroom
 
spope's Avatar
 
Join Date: Feb 2004
Location: Io
Age: 35
Posts: 233
Re: Engine Run-On in EA MPFI (Converted)

It's not my timing - my timing is in fact retarded at the moment by a couple of degrees.
I am now almost positive it's a tps issue, as my tps is playing up big time. I'll fix it this weekend.
The other thing is that I am still using the cfi power relay for the ecu, which has a 30-second delay built into it, is it possible that the ecu is still firing the injectors after the ignition is switched off?

EA GL-Ghia pseudo operator
3.9 MPFI converted 4 speed
2.5 inch exhaust
NC Ghia interior (except rear trims)
Fairmont audio (with 4 speakers)
Cruise control
S-pac cluster with white dials
Trip computer and Fairmont interior lighting.
Half wired Ghia BCM.
spope is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Update - EA engine repair or replace. prabbit Inline 6 Tech 0 06-01-04 06:22 AM
Rmyers now officially drives a mpfi EA :D Rmyers Inline 6 Tech 52 02-25-04 08:30 PM
EA engine problems - revisited (like the Matrix LOL) Axeman82 Inline 6 Tech 4 11-04-03 11:46 PM
EA engine, driveline, interior into another EA shell Falcon_Spac Trans | Driveline 18 07-01-03 05:48 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome