FE LTD Timing Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-16-2004, 18:46   #1 (permalink)
FE LTD
 
Join Date: May 2004
Location: Gold Coast
Posts: 4
FE LTD Timing Problems

My 85 LTD (Leaded) is playing up and I can't seem to work it out this time. Its sure got has got me stumped.

After the car has been running a while on the freeway, when you come off into slower traffic, slow at lights etc the ignition timing goes all over the place and the car can barely move and eventually stalls.

Given it being an ignition problem, I have over time eliminated such problems, but this time I cant. The car has good leads, a newish coil, and a brand new module, but still is playing up.

After the car sits for a while, it starts fine, and drives perfect, until you have run a while and come into slower speeds/up hills.

Not fuel related as it does it on LPG as well.

Most mechanics I talk to have no idea, thus me not leaving it with them!
FE LTD is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clevo into FE LTD (XF) G.G.LTD Australian Falcons 6 03-13-2004 03:45
4.1 EFI XF (LTD) idle problems flacco General Tech 5 02-04-2004 15:22
Ford blames its suppliers for quality problems, demands improvement Stacy94PGT Ford Worldwide News 0 05-28-2002 08:58
Timing problems Danno General Tech 2 03-08-2002 15:57
FE LTD Interior in XE Ute QuarterPounder Interior | Electrical | ECU 2 11-03-2001 01:58

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:52.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.