help identify sensor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-12-03, 02:28 PM Thread Starter
Registered User
 
PerformanceX2's Avatar
 
Join Date: Aug 2003
Age: 38
Posts: 25
help identify sensor

A garage said this sensor is bad. Dude called it a "PFE sensor". No one else seems to know what it is.
It's a small black plastic box, with a grey wire connector coming off the bottom, and a black vacuum line off the bottom center, that goes to what I believe is the EGR valve.
Does anyone know the correct name for this thing?
This is an 85-86 2.9L fuel injected.

Attached Images
File Type: jpg PFEsensor2.jpg (49.3 KB, 29 views)
PerformanceX2 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-13-03, 10:02 PM
Registered User
 
'92BigBronco's Avatar
 
Join Date: Aug 2003
Posts: 340
PFE stands for Presure Feedback EGR. They can usually tell if it's bad or not by pulling a code. I believe code 336 is the PFE code.

1992 Ford Bronco
351W
E4OD- B&M Stage 2 shift kit
Full 3" stainless Bassani Exhaust
32" BFG's/stock suspension

"No replacement for displacement."

"Our lugnuts require more torque than most Honda's produce!"
'92BigBronco is offline  
post #3 of 3 (permalink) Old 08-14-03, 09:06 AM Thread Starter
Registered User
 
PerformanceX2's Avatar
 
Join Date: Aug 2003
Age: 38
Posts: 25
Re: help identify sensor

Great, thanx!
PerformanceX2 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure sensor brenlam Australian Falcons 4 03-28-03 02:47 AM
Cooling Fan sensor problems '91 Tempo Mike Pfleger Ford Tempo Forum | Mercury Topaz Forum 0 08-11-02 06:08 AM
Water Sensor DansEdgli General Tech 7 07-06-02 03:23 AM
Understanding Engine Management - Part 1 Dan [Sac] V6 and Hot4 Tech 0 12-11-01 01:08 PM
Replacing Cam Position Sensor sableman General Tech 1 07-05-01 02:21 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome