I6 Revs slow to drop? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-08-2002, 16:39   #1 (permalink)
Registered User
 
EddyBigShoes's Avatar
 
Join Date: Aug 2002
Location: Brisbane
Posts: 34
Question I6 Revs slow to drop?

I have a curious problem with my XH XR6 manual ute. When I rev the engine to 5000rpm then let the revs drop, it takes ages to go down back to idle! However when I turn the aircon on it drops back quickly as I would expect it to. Otherwise the engine runs great.

Is there something wrong with my engine or do they all do that?
__________________
- Present - XH XR6 Falcon Ute
- Past - s14 Nissan 200sx
EddyBigShoes is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-08-2002, 19:38   #2 (permalink)
EA Falcon.com Member
 
Join Date: Sep 2002
Location: Melbourne's West
Posts: 90
Back when I had a problem with my TPS in my falcon it used to do the same. Normally I would ask if the car cruises along on its own at 60km/h without any pressure on the throttle, but the engine braking from a manual would overcome this anyway. You should be able to take the car somewhere and get the TPS checked out to see if it is putting out the correct voltage (I do not know how to do this so I can't help you there)
__________________
Clutterz

3.9 CFI Falcon. King Springs, Monroe GT Shockers. Formula 1 Tinted windows. Pioneer 3350 Head Unit, 12" JL Audio Sub. 6"-9" Pioneer 3 Ways, 4" Clarion 2 Ways, 500watt Schneider Amp, 222watt Sony Xplode Amp. Really shitty 14" Jelly Beans
Clutterz is offline   Reply With Quote
Old 12-08-2002, 22:36   #3 (permalink)
Looking in YOUR bathroom.
 
Join Date: May 2002
Location: Adelaide
Age: 31
Posts: 3,287
I think i have this problem. When i give her a big rev in neutral it drops the reves down to 1200-1500, but then takes a good 5seconds to drop of idle. The car also cruises at 60 with no throttle, and will creep into 3rd gear and arround 40kmh, with no accelrator. Sounds like TPS?
Walkinshaw is offline   Reply With Quote
Old 12-08-2002, 22:47   #4 (permalink)
Registered User
 
EddyBigShoes's Avatar
 
Join Date: Aug 2002
Location: Brisbane
Posts: 34
Excuse my ignorance but what is a TPS?

When cruising at 60 and taking my foot off the accelerator it does reduce speed but very slowly. At 100 its almost like cruise control, when there's a downward slope it picks up speed meaning I have to constantly tap the brakes to stay under the speed limit.
__________________
- Present - XH XR6 Falcon Ute
- Past - s14 Nissan 200sx
EddyBigShoes is offline   Reply With Quote
Old 12-08-2002, 22:52   #5 (permalink)
Territory TS - AWD
 
RAPTOR's Avatar
 
Join Date: Feb 2001
Location: Kiama, NSW, Australia
Age: 51
Posts: 2,374
TPS = throttle position sensor

It tells the engine computer how far you have the boot into it.
__________________
Territory - WHEELS COTY
RAPTOR is offline   Reply With Quote
Old 12-09-2002, 07:05   #6 (permalink)
Two SC 61's = trouble
 
ebxr8240's Avatar
 
Join Date: Jul 2001
Location: Penrith,nswAus/Morrinville.NZ
Age: 61
Posts: 6,360
Check for inlet leaks.Check Idle motor[iac]? May be crud in there jaming it..Check pcv .. it maybe venting always..Even manifold temp senser?? The eec thinks its cold ??..Or idle speed too high..
__________________
Don't be afraid to try something new. Remember, amateurs built the Ark...Professionals built the Titanic!
.
Tuned & maintained by "Peppertree Perfmormance". Dart block, Scat 4340 steel crank, Custom C.P pistons.Oliver rods.. Mal Wood twin plate clutch.. Twin SC61/2's,482 rwkw/ 645 rwhp..
Passengers, myocardial infarction material..
R.I.P Possum...
ebxr8240 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Revs dropping too fast during changes. cArSiK General Tech 34 03-11-2003 03:50
T5 i6 / V8 difference honer Inline 6 Tech 20 03-09-2003 02:14
BA Falcon Engine Reveal RPO83 Ford Worldwide News 0 09-04-2002 08:27
revs are slow to come down NAPARM General Tech 10 06-14-2002 20:43
Why do the Revs drop? Griffyn General Tech 5 04-19-2002 00:25

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:39.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.