Ignition Advance Problem on 4.0L - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-30-04, 12:31 AM Thread Starter
Registered User
Join Date: Sep 2003
Location: Sydney
Posts: 141
Ignition Advance Problem on 4.0L

My XH suddenly lost power on the highway due to what seems like 2 faults, first up the fuel filter was almost totally blocked, I replaced it and cleaned the injectors etc, but now when I put a timing light on it in normal mode, reving the engine will only give me about 10-15 deg of advance. On my V8 I get 30 or more by just giving it a quick rev. I swapped the ECU and MAP sensor, no change. Has my TFI module died? I suspect not because I do get some advance. How much advance do you blokes get when giving your I6 a quick rev in normal run mode?

My tag line sucks, can I borrow yours?
edv8wagon is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
XR6T problem in SMH Aussie Falcon F6 Typhoon | XR6 Turbo 7 12-06-04 03:26 AM
Escape 2005 Ignition lock problem chauffer Ford Escape | C-MAX | Mercury Mariner Forum 0 11-15-04 12:26 PM
Anyone had this gearbox problem??? XR6HP01 Trans | Driveline 16 08-31-03 08:32 PM
96 taurus ignition problem...please help??? ghost rider Interior | Electrical | ECU 3 08-21-03 04:54 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome