just a bit useless information - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-01-04, 04:08 AM Thread Starter
Registered User
 
Join Date: Jul 2002
Location: melbourne
Posts: 249
just a bit useless information

G'day thrillseekers.

Well I've really had a good day. i have replaced all the injectors in the beast. I decided to do this 'cos the idle has been really rough lately, and from past experiences, the rubber "O" rings on the injectors seem to turn to crap after about 100,000 k's. and mine have done about 150,000

Anyway I bought a complete new set from Powerflow (Ringwood, and no, this is not a plug for them) for $322 delivered, and set to replacing them. All went well until I fired the motor, and it ran like a sick dog, burping and farting and running really rich. You could smell it. Took it for a drive, thinking the ECU might need to think about things a bit, but it was no better.
Anyway, we sat down, had another tube, and started the engine again. It was then that I heard a hissing sound. Vacuum leak !!!!!!. I had accidentaly knocked off a vacuum hose!!!! Put it back, and it ran as sweet as a nut.
Feels much stronger and idles really well. All in all it took us about 4 hours and 6 cans to do the job.

Keep the shiny side up

creature3 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-03-04, 07:57 AM
Registered User
 
ebs_4l's Avatar
 
Join Date: Jun 2003
Posts: 476
Re: just a bit useless information

what an appropriate thread name...

eb6, t5, stg3 crow, chip, ceramic button clutch, pacemakers, 2.5in stainless, unifilter pod, ported head, thermos, pedders s/low, LSD.... 144.5rwkw so far
ebs_4l is offline  
post #3 of 3 (permalink) Old 05-03-04, 07:33 PM Thread Starter
Registered User
 
Join Date: Jul 2002
Location: melbourne
Posts: 249
Re: just a bit useless information

That's what I thought too. My life has been a bit slow lately........................
creature3 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
request of tech information LunaticSVT Model A & Model T 0 05-22-03 10:49 PM
AV info - can we post info from another Forum? Falchoon The Pub 123 05-17-02 12:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome