My EA is giving me a headache?????? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-26-05, 07:43 PM Thread Starter
Registered User
 
Join Date: Jan 2005
Posts: 2
My EA is giving me a headache??????

This is my first post here and i don't know where to get started.

I have a EA 91 CFI anniversary edition with a 4 speed auto, and it's starting to irritate me.
When the car is cold it starts and accelerates perfectly. Once the car reaches normal operating temp, it seems to lose power.
If it's a hot day outside, and the car is at its normal operating temp, it will lose of power, and if i have the air con on, and i am about to take off at a set of lights, the car will accelerate so slow, that i have to turn the air con off, just to get some acceleration happening, but it's still pretty sluggish.

Also on hot days, the car tends to stall when i am idleing at a set of traffic lights for a peroid of time. And it won't want to start for about 2 mins or so.

Also when i drive the car around on a hot day, and then stop the car, for about 10 to 20 mins, and then turn the car on again to drive, the car won't want to start. The engine turns over but the car won't start for about 5 to 10 mins, and when it does start it idles erratically for a few mins, then it idles well and i am able to drive away.

Can someone please help, i am tired of going through this hassle.

Phreakin79 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-27-05, 04:12 PM
Registered User
 
Ruger's Avatar
 
Join Date: Jun 2003
Location: Sydney
Posts: 430
Re: My EA is giving me a headache??????

it could be the fuel pump because aparently ea fuel pumps hate the heat
Ruger is offline  
post #3 of 3 (permalink) Old 01-28-05, 12:29 AM Thread Starter
Registered User
 
Join Date: Jan 2005
Posts: 2
Re: My EA is giving me a headache??????

Thanks for that, i will look at getting a new fuel pump. But will the fuel pump make my car lose power when it reaches operating temp????
Phreakin79 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing trims from EA to EB DragonLady68 Interior | Electrical | ECU 4 11-16-04 04:00 AM
EA to ED Falcon review Aussie Falcon The Pub 13 08-24-04 08:35 PM
clear indicators in EA falconS Interior | Electrical | ECU 24 07-16-04 04:17 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome