Solution found for: EBII top radiator hose posting - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-28-03, 08:09 PM Thread Starter
Registered User
Join Date: Jun 2003
Posts: 50
Solution found for: EBII top radiator hose posting

Howdy Pilgrims,

Some time ago I made the following post:

Got a queer one. Top radiator hose is soft after car is warmed up. However, it never overheats, there is coolant cycling into the overflow tank and there are no signs of head gasket failure.

Had the radiator split and flushed approx. 15,000k's ago, coolant is nice and green with no scum accruing around the overflow tank. New hoses top and bottom. Also replaced the cap just to be sure.

Occasionally (3 times in the last 8 months) I seem to have a mammoth loss of coolant. None of goes onto the driveway, or out the exhaust. From what I can tell it only happens when give the car a hard time (seldom...).

OK, well, the other day it was rather hot here in Brisbane, had the airconditioner going full tit and a 'license to fang' from my lady as she had to get to the bank ontime. When I get out of the car there is collant pi**ing out the front of it. Bugger.

Discovered that my surge tank was doing a fine impression of a sprinkler, being cracked along the top/bottom joint on the front left hand corner. This is the first time since I posted the previouse message that I have flogged the car on a hot day with the aircon on.

Anyway, replaced the surge tank on Sunday (no you can not get the drain plug back in once removed, especially when the coolant is not fully cooled, ouch). Car is now running a little cooler and the TOP RAIATOR HOSE IS NOW HARD!!! yay for me. It appears this was my problem all along, but only surfaced under hard conditions in summer.

Last edited by Gargoyle; 09-28-03 at 08:11 PM.
Gargoyle is offline  
Sponsored Links
post #2 of 2 (permalink) Old 09-29-03, 12:55 AM
NB & NCII V8 Fairlanes
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 3,072
Re: Solution found for: EBII top radiator hose posting

Good news. We'll all file that one away in our memory banks.

Regards Blue
Aussiblue is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone need a carfax? GASGUZZLER007 The Pub 16 07-20-03 08:49 AM
A Legendary Car Is Found RPO83 Ford Worldwide News 0 07-28-02 10:49 PM
Sneezing driver found guilty Falchoon The Pub 4 04-04-02 05:37 PM
Dealership sues customer over message board posting raitchison The Pub 15 11-26-01 11:21 AM
Anyone needs a carfax? GASGUZZLER007 The Pub 8 11-13-01 08:45 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome