XD/XF Idle / Ignition?? Fault - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-01-05, 12:15 AM Thread Starter
Who wants more than 80kw?
Join Date: Jan 2005
Posts: 95
XD/XF Idle / Ignition?? Fault

Hi all,

Ive just fitted a dissy out of an XF EFI (with the hall effect sender) from the wreckers hooked up with a Silicon Chip High energy ignition to an XD.

Pulled up at BP today to fill up with ultimate, went to leave and it wouldnt start. After pushing it out of the way... I fiddled around with the new wiring and it ran... for 50 metres then proceeded to break down again. (luckily in front of a deli so I got some lunch)

Got assistance 20min later and it started then ran home perfectly.

The only thing which is weird is that when it idles on GAS or petrol under no load it 'burbles' and misses a bit. When you hook up a strobe to no 1 cyl it also seems a little intermittant, yet the tacho is rock steady.

Does anyone know the history on the hall effect sensors in those dissys? Were / are they unreliable? The reason I ask is that a third party one is worth $120!?!?

Ive checked, double checked and spent all of yesterday and today looking at my wiring and the High energy ign. I even bypassed all of the safety switches on the gas, checked for vacuum leaks, replaced plugs, leads, dissy cap, rotor button... etc.

81foXDwagon is offline  
Sponsored Links
post #2 of 3 (permalink) Old 02-02-05, 11:12 PM
sideways in a six
Join Date: Aug 2003
Location: Canberra
Age: 28
Posts: 187
Re: XD/XF Idle / Ignition?? Fault

not that it helps, but Jaycar were selling a hall effect sensor identical to the bosch ones for around $30-$50 (if that ends up being the problem). Timing's right, is it doing anything weird cause of the PVS (if it's still there) messing with timing, etc?

...someone give me a steep hill
meethed is offline  
post #3 of 3 (permalink) Old 02-03-05, 02:12 AM Thread Starter
Who wants more than 80kw?
Join Date: Jan 2005
Posts: 95
Re: XD/XF Idle / Ignition?? Fault

Thanks 4 that meethed, ive just had a look at the jaycar site, $20.

I think my fault is in my S/C High energy ignition module. I took the dissy out of the block, put a spark plug on a lead straight out from the coil and turned on the ignition. As I spun the distributor the plug sparked, however after about 5 turns it stopped.

What was really weird was the when I got into the car and got a mate to turn the dissy, the tacho was still registering the right RPM. Obviosly the coil isnt getting any power due to something dodgy in the kit. (ive tried about 3 coils).

I think i'll take a trip to jaycar tomorrow and buy all new parts, including the hall effect. Hopefully that will fix it, as ive spent $120 so far on this conversion.....

I did however have some luck today. Spend $50 on a xenon discharge timing light. Managed to tune up my other car in the daylight
81foXDwagon is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
DTC Codes fordel Ford Focus Forum 8 02-22-09 12:22 AM
**SOLUTION** to Idle probs with big cam!!! ftr_el Inline 6 Tech 14 10-28-04 05:47 AM
DIY Ignition coupefan Interior | Electrical | ECU 3 04-20-04 08:17 PM
XR8 auto gear position fault ? (detailed) EL1XR8 Trans | Driveline 2 02-13-03 12:44 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome