XF Speedo Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-15-04, 06:44 AM Thread Starter
Registered User
Join Date: Jul 2003
Posts: 8
XF Speedo Problem


I have a '85 XF 4.1 EFI auto

I've just changed the gearbox with a box I exchanged from the local wreckers and while everything is operating aok, the speedo isnt reading right. It seems to be reading 10-20km under what I think Im doing - judging from travelling with other cars on the road (ok, not exactly the most accurate method). The needle takes longer than usual to start registering the speed.

The exchange box came with the speedo sensor intact and I left it in there - was that a bad move? I left the original sensor in the original box. Is there any adjustment I should do with the sensor? I noticed that it can rotate a bit when tightened up. Reading elsewhere in these posts, I found that there is a adjustment screw on the back of the cluster.

any ideas?
timbo999 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 04-15-04, 08:55 AM
Registered User
Join Date: Nov 2002
Location: Brisbane
Age: 40
Posts: 292
Re: XF Speedo Problem

Grab the transducer out of your old box and put it into the replacement.. should do the trick.

The diff the other box came out of was most likely a diff ratio.. or the transducer in it is simply stuffed.

Transducer is the speedo drive near the rear of the gearbox with a few wires coming out of it.. from memory on the drivers side.
eskyboi is offline  
post #3 of 3 (permalink) Old 04-18-04, 04:55 PM Thread Starter
Registered User
Join Date: Jul 2003
Posts: 8
Re: XF Speedo Problem

Probably getting the transducer will do the job - just need to get back to the wreakers to see if they'll exchange it!
timbo999 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem from other forum uhzid Ford Focus Forum 5 03-10-04 02:39 AM
ef I-6 into xf or stick with old? jAcKaL Inline 6 Tech 7 11-09-03 05:16 PM
Anyone had this gearbox problem??? XR6HP01 Trans | Driveline 16 08-31-03 08:32 PM
xf efi problem XFwagon Inline 6 Tech 6 06-17-03 01:53 AM
Defective GM engines $30+ Bilion problem. Discovery The Pub 11 03-21-02 07:37 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome