XR6 valve problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-01-03, 05:18 AM Thread Starter
Registered User
Join Date: Jul 2003
Posts: 5
XR6 valve problems

Has anyone experienced problems with the valve springs of the BA XR6 Turbo six? Mine has once or twice briefly run rough and I've been told those engines have "weak" valve springs? Any takers?
Prodrive is offline  
Sponsored Links
post #2 of 5 (permalink) Old 08-01-03, 07:31 PM
Australian Falcon Member
Join Date: Jun 2001
Location: Western Australia
Posts: 865
Not sure if it'd be related to your experience, but apparently with the AU they went to single coil, conical type valve springs - the purpose was for "low drag" valve train.

Now I'm not sure if BA's have that type of spring setup, but I could well imagine that if you do have them then under certain circumstances it would be quite possible to have them maybe flutter a bit.

So the reference to "weak springs" might be a recognition that the new fangled single springs aren't quite as good in performance applications as the traditional double design.


Last edited by EDFUTURA; 08-01-03 at 07:52 PM.
EDFUTURA is offline  
post #3 of 5 (permalink) Old 08-01-03, 10:29 PM
blue blooded
svtang's Avatar
Join Date: Feb 2003
Location: being blue blooded
Posts: 278
Re: XR6 valve problems

who told you about the weak valve springs?
why do you ask? why do you invite "any takers"?

if you have ever felt lash adjusters bleed down I suggest respectfully that one would not have to think if it happened once or twice ... and it certainly doesn't happen briefly


forced induction at 7000rpm .... it says it all

xr6t ute (289rwkw and fast) & blown Mustang Cobra (347 rwkw and faster)
svtang is offline  
post #4 of 5 (permalink) Old 08-02-03, 07:37 AM Thread Starter
Registered User
Join Date: Jul 2003
Posts: 5
Yeah, I think that's probably right
Prodrive is offline  
post #5 of 5 (permalink) Old 08-03-03, 08:04 AM
Registered User
ebs_4l's Avatar
Join Date: Jun 2003
Posts: 476
Re: XR6 valve problems

your problem sounds to me like vct actuator blockage, they have problems with these blocking, we have had to clean a few of them at work, i had to do a set on a turbo the other day, when they block up the run like shit..
ebs_4l is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Inline 6 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
XR6 Turbo Oil Temp problems? SimonH F6 Typhoon | XR6 Turbo 8 08-06-03 08:54 AM
weird problems eb xr6 TUFESP General Tech 11 02-14-03 06:51 PM
EF XR6 Idle/stalling problems QuarterPounder Inline 6 Tech 11 12-05-02 08:47 PM
Au 3 Xr6 Ute Problems Help~~ wagonmaster Inline 6 Tech 9 09-30-02 08:55 AM
heat riser valve problems GendoIkari69 Ford Bronco Forum 0 10-02-01 08:34 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome