cleveland in xb problem. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Cleveland Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-04-2003, 18:17   #1 (permalink)
Registered User
 
Join Date: May 2002
Location: melbourne
Age: 33
Posts: 368
cleveland in xb problem.

Hi all,

My 351 cleveland in xb is having some probs. I think it is flooding but i am not sure so i will try to explain it as best i can.

I can get it started after a few tries but it will only continue running if i hold my foot on the acclerator so its going at around 1200-1500 rpm. If i take my foot of it wont idle at all and dies straight away. While its running there is drops of what i think is petrol coming out the exhaust. Also it runs really rough and feels like some cylinders arent firing sometimes. If i try to put it into gear (auto) to drive it just coughs and splutters a bit and dies. Does this sounds like flooding or another problem? I had it dyno tuned a few weeks ago and the guy there said the carby needs some work but didnt pick up any other probs with it. It was running really well after that until one day i started it, left the house and it started struggling a bit under load. It did this twice for about 5 k's then the next day it was fine again. Was fine for a few more days then started the prob again now its so bad i cant drive it. I want to be sure so if it is carb i can just take it off and get it rebuilt rather than trying to get the whole car somewhere.

Carb is a carter afb as far as i know. Looks like the ones ive seen on the edelbrock website but not sure exactly what it is.

Any ideas guys?

Thanks

Aaron
xespack is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-04-2003, 19:29   #2 (permalink)
Two SC 61's = trouble
 
ebxr8240's Avatar
 
Join Date: Jul 2001
Location: Penrith,nswAus/Morrinville.NZ
Age: 61
Posts: 6,360
Re: cleveland in xb problem.

Needle and seat warn or some crud in there preventing correct sealing...Check floats and float level.Sometimes a rebuilt or new carb is heaps easier option ....

If you can try reving engine quite high and put hand over carb so it sucks things clear in carb maybe ...
__________________
Don't be afraid to try something new. Remember, amateurs built the Ark...Professionals built the Titanic!
.
Tuned & maintained by "Peppertree Perfmormance". Dart block, Scat 4340 steel crank, Custom C.P pistons.Oliver rods.. Mal Wood twin plate clutch.. Twin SC61/2's,482 rwkw/ 645 rwhp..
Passengers, myocardial infarction material..
R.I.P Possum...
ebxr8240 is offline   Reply With Quote
Old 12-05-2003, 02:57   #3 (permalink)
Falcon 2.. Ferrari 0 hehe
 
MaD_WoG's Avatar
 
Join Date: Aug 2003
Age: 31
Posts: 1,290
Re: cleveland in xb problem.

exactly the same thing is wrong with our xb 351..
MaD_WoG is offline   Reply With Quote
Old 12-05-2003, 04:48   #4 (permalink)
V8 XW Ute/APV Kitted EBII
 
ViGiLaNtE's Avatar
 
Join Date: Dec 2002
Location: Sydney - West - Originally Tas
Posts: 472
Re: cleveland in xb problem.

It will be a float thing or N & S...put a kit through it and make sure u r running fuel filters inline and in the carby inlet itself.

Mixture screws rule of thumb..(with Holleys anyway) screw all the way in...then unscrew about 1-1/2 to 2 turns each one.

ViGiLaNtE
__________________
Nothing beats the sound of a V8
ViGiLaNtE is offline   Reply With Quote
Old 12-05-2003, 19:41   #5 (permalink)
Registered User
 
Join Date: May 2002
Location: melbourne
Age: 33
Posts: 368
Re: cleveland in xb problem.

I wouldnt have a clue how to adjust or check needle and seat. I was having a play around with it today and no luck. If it is leaning out rather than flooding would this hurt the motor runnning it in the drive way for like 10 mins? i tried holding it at about 2000 rpm and shutting choke and putting my hands over it as ebxr8 said but nothing so i guess i will have to take it of and have it rebuilt etc.

Thanks guys
xespack is offline   Reply With Quote
Old 12-05-2003, 23:45   #6 (permalink)
Registered User
 
Join Date: Sep 2002
Location: 27 00S 153 07E
Posts: 1,944
Re: cleveland in xb problem.

Probably just some crap in it.

Try pouring some Redex down the throat while your mate keeps the revs up to prevent stalling. Just dribble it in - rev it well -makes heaps of smoke to impress the neighbours.

Do they still make Redex? If not, some Caltex Techron or similar.

cheers
__________________
"I married Miss Right. I just didn't know her first name was Always."
TopGhia is offline   Reply With Quote
Old 12-08-2003, 16:15   #7 (permalink)
74 XB Fairmont
 
brenx's Avatar
 
Join Date: Sep 2001
Location: Cranbourne, Vic
Posts: 5,113
Re: cleveland in xb problem.

I've just had the same issue as my carb/engine etc was sitting around for about 6mths. When it first fired it fired on all 8, then slowly carboned the plugs, then went on the not start at all.

I tried everything, including another dizzy, I spent $215 on my electronic dizzy replacing parts.

I set everything up on 10 deg with a points dizzy, it fired up, ran it for about 20 mins, left it setup @ 10 deg, threw the electronic back in and alls good so far.

My guess is jammed neddle and seat? Or crap in the bowls/line?? I never found my problem, it just went away.

Make sure the idle mixture screws are correct also, as thats stop it idling.

Brenden
__________________
XB Fairmont (street car) 11.07@123.02mph.
brenx is offline   Reply With Quote
Old 12-11-2003, 03:48   #8 (permalink)
Registered User
 
Join Date: May 2002
Location: melbourne
Age: 33
Posts: 368
Re: cleveland in xb problem.

Had the carby reco'd. Put it back on today and the problem is still the same.

What else should i try? Could it be an ignition problem?
xespack is offline   Reply With Quote
Old 12-11-2003, 03:57   #9 (permalink)
74 XB Fairmont
 
brenx's Avatar
 
Join Date: Sep 2001
Location: Cranbourne, Vic
Posts: 5,113
Re: cleveland in xb problem.

I personally think it's a timing issue. This is what I'd do in order:

a) remove plugs (clean with wire brush). A badly carboned plug won't fire.
b) Check for spark and fuel
c) set timing (static) @ 6-10 deg BTDC
d) check for vacuum leaks on the inlet manifold, although air sucking from the valley is hard to find. So if your suss on the inlet gasket? It could be $15 well spent.

Brenden
__________________
XB Fairmont (street car) 11.07@123.02mph.
brenx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Cleveland Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone had this gearbox problem??? XR6HP01 Trans | Driveline 16 08-31-2003 20:32
95 CV engine problem 95CV Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 9 04-22-2003 21:17
SHO stopper: Engine problem in high-performance Taurus angers fans Stacy94PGT Ford Worldwide News 0 10-23-2002 22:39
XB Electrical Problem - URGENT HELP NEEDED uteman Classic Falcons 19 06-22-2002 05:39
Defective GM engines $30+ Bilion problem. Discovery The Pub 11 03-21-2002 19:37

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:49.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.