No power ! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-30-04, 11:00 PM Thread Starter
Registered User
Join Date: Sep 2004
Posts: 10
No power !

As I posted in the Fairlane page I got no power ! I got a 302 Clevo in a 76 Fairlane Marquis and well I'm struggling with power at the moment. Don't know what's wrong with it. Think it has fuel problems as it chokes a bit when the pedal is dumped down a bit and well i've had some problems getting it up the bloody drive way because there is just no power at the wheels. Have to put it in neutral rev the crap out of it then stick it in drive or reverse to get it up there some times and let me tell you my drive way ain't that steep.
Zh Marquis is offline  
Sponsored Links
post #2 of 5 (permalink) Old 12-30-04, 11:16 PM
74 XB Fairmont
brenx's Avatar
Join Date: Sep 2001
Location: Cranbourne, Vic
Posts: 5,113
Re: No power !

Sounds like you more than 1 problem.

That stumbling could be the accel pump on the carb is worn out. As for no power @ the wheels either you've got an issue with your rear brakes or a problem with the transmission.

Check the transmission fluid and linkages. Also sounds like it has a serious engine issue. The only time mines been like that is when I had bent 2 valves.


XB Fairmont (street car) 11.07@123.02mph.
brenx is offline  
post #3 of 5 (permalink) Old 12-31-04, 11:50 AM
Registered User
TruBlu351's Avatar
Join Date: Apr 2003
Location: Newcastle
Posts: 2,398
Re: No power !

How does it rev once its got over its bogged down phase?

Does the rpm just just hang low or is it revving hard with no power?

Have you checked the basics like timing and good spark/ignition?

Are you running old points in your dizzy? Check your dwell gap.

XE Falcon
393 Tremec TKO 9"
TruBlu351 is offline  
post #4 of 5 (permalink) Old 01-01-05, 09:15 PM
Registered User
Join Date: Nov 2004
Age: 37
Posts: 57
Re: No power !

sounds like timing to me
old falcon fan is offline  
post #5 of 5 (permalink) Old 01-03-05, 07:04 PM
Registered User
mattlea1's Avatar
Join Date: Dec 2004
Age: 41
Posts: 243
Re: No power !

I had a similar problem with my LTD in the end i changed the Thermoquad carby for a 600 Holley and problem solved.
mattlea1 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Cleveland Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Drive article: XR8 vs SS FPRXR-6 Australian Falcons 32 02-22-05 04:48 AM
Here we go again. Supercar Scare!!! EL2 XR8 The Pub 59 08-11-04 11:11 PM
95 Escort lack of power lawton_kid Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 6 02-04-04 02:44 PM
U.S. Ford-Dodge ad battle is a truck, TV power play Stacy94PGT Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel 1 01-17-04 04:09 PM
no power 85GMarquis Interior | Electrical | ECU 2 10-22-03 02:58 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome