Popping/backfire through carb on quick accelerations - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-09-09, 08:36 PM Thread Starter
Registered User
Join Date: Apr 2009
Posts: 7
confused Popping/backfire through carb on quick accelerations

Hello everyone!

Still having a problem w/ the Mach 1:

Problem: A "popping" noise/small backfire from the carb when the throttle is opened quickly and only quickly. If it is opened slowly the engine will spool up just fine and everything sounds great. The popping happens more easily when the engine is under load. For audio/visual reference please watch this clip:

YouTube - Mach 1 First Run 4 08 09

Car is question:
1973 Mach 1
4160 600cfm Holley
351 C
4 speed

I would really like to get this car to the big show at the University of Maryland (April 26). I'm thinking a valve or timing chain problem off hand?? Please help!! Thank you!!
351Powered is offline  
Sponsored Links
post #2 of 3 (permalink) Old 04-26-09, 07:17 AM
Registered User
xrfairmont67's Avatar
Join Date: Dec 2008
Location: adelaide
Age: 47
Posts: 7
Re: Popping/backfire through carb on quick accelerations

it sound like its a lean backfire. remove the air filter and look down the front barrels of the carby. in the cetre u will see a phillps head screw holding the squirter in . when u blip the accelerator fuel should flow from there straight away. the very first 3-5mm movement it should be spraying fuel. i would first check the accellerator pump on the lower rh side of the front fuel bowl (looking at carby from front of car). there is an adjustable bolt/nut with a spring . 3/8 head . put a spanner on bolt head and nut head and turn out half a turn at a time. start car and check. readjust if needed. other than that it may be the accellerator pump diaphram need replacing..
xrfairmont67 is offline  
post #3 of 3 (permalink) Old 06-02-09, 10:36 AM
Registered User
Join Date: Jun 2005
Location: Melbourne
Age: 33
Posts: 111
Re: Popping/backfire through carb on quick accelerations

hey mate.

i agree with the idea of a lean backfire but would also like to add check the ignition leads. i had the same set up as you on my 351 as may ppl do and mine was a silicon lead breaking down under load. i replaces the leads with a set of bosch stainless core type and the problem went away.
ziggs is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Cleveland Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome