suspected starter problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-12-06, 01:54 AM Thread Starter
Registered User
Join Date: Dec 2005
Location: Sydney
Posts: 17
suspected starter problems

Hi guys,
I went to head off for work tonight and the clevo fired, disengaged the starter and then re engaged it and the motor died. After that the starter would not engage the motor for more than a second or so, not quite enough to fire.
All connections are still good and the starter will continue to turn after it disengages.
I assume I'm looking at a new starter, any suggestions on make style etc in sydney and prices.

I also checked the battery and it is good to go.

Appreciate any help I can get.

Clevo is in an 81 Bronco, if it matters.
Wet Ones is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Cleveland Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome