WTF is my oil pressure? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Cleveland Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-01-2005, 05:38   #1 (permalink)
74 XB Fairmont
 
brenx's Avatar
 
Join Date: Sep 2001
Location: Cranbourne, Vic
Posts: 5,113
WTF is my oil pressure?

I have the sump off.

Oil pump is submerged in oil and pumps oil without much effort.
Oil pump drive is fine. It's an aftermerket one.

I'm going to replace the pump anyway but doesn't anyone have any ideas on why I have no oil pressure @ the sender? I use an idiot light and mech pressure guage @ the sender. I removed the fitting from the block where the senders go and I still had no oil pressure.

While I stew on it some more I'm refering to my manuals.

Brenden
__________________
XB Fairmont (street car) 11.07@123.02mph.
brenx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-01-2005, 05:49   #2 (permalink)
ZK 351
Guest
 
Posts: n/a
Re: WTF is my oil pressure?

dead sender?, blocked oil gallery, dead press gauge?
mabey borrow a gauge, try a different sender,
other than that, no other suggestions than to change pump, and if that doesnt fix it, back to blocked gallery,

hasnt flogged out the hex fitting inside the end of dizzy shaft has it? (damn unlikely)
few things to think about if you arent already thinking about them
  Reply With Quote
Old 06-01-2005, 05:53   #3 (permalink)
74 XB Fairmont
 
brenx's Avatar
 
Join Date: Sep 2001
Location: Cranbourne, Vic
Posts: 5,113
Re: WTF is my oil pressure?

How can it be a dead sender when I removed the oil pressure gauges from the block. Theres nothing blocking the oil gallery at the back of the block. Oil should squirt everythere when nothings in the sender hole under cranking. Oil doesn't seem to be getting that far?

Stupidly enough I have no oil leaks whatso ever.
__________________
XB Fairmont (street car) 11.07@123.02mph.
brenx is offline   Reply With Quote
Old 06-01-2005, 05:55   #4 (permalink)
ZK 351
Guest
 
Posts: n/a
Re: WTF is my oil pressure?

ah ok, i see, yeah well all thoughts i had above, doesnt sound good, probably the pump
  Reply With Quote
Old 06-01-2005, 05:57   #5 (permalink)
74 XB Fairmont
 
brenx's Avatar
 
Join Date: Sep 2001
Location: Cranbourne, Vic
Posts: 5,113
Re: WTF is my oil pressure?

nope not the pump or the drive? Did you read my post? I have the sump off. I have tested the parts.
__________________
XB Fairmont (street car) 11.07@123.02mph.
brenx is offline   Reply With Quote
Old 06-01-2005, 11:09   #6 (permalink)
Pommey Mustanger
 
mach1mike's Avatar
 
Join Date: Apr 2004
Location: Cornwall UK
Posts: 139
Re: WTF is my oil pressure?

could it be an oil filter problem Bren?
mach1mike is offline   Reply With Quote
Old 06-01-2005, 15:53   #7 (permalink)
74 XB Fairmont
 
brenx's Avatar
 
Join Date: Sep 2001
Location: Cranbourne, Vic
Posts: 5,113
Re: WTF is my oil pressure?

I'll replace it and see. The other filter wasn't old but I'm looking everywhere.
__________________
XB Fairmont (street car) 11.07@123.02mph.
brenx is offline   Reply With Quote
Old 06-01-2005, 17:54   #8 (permalink)
Registered User
 
Racer's Avatar
 
Join Date: Oct 2002
Location: Sydney
Posts: 992
Re: WTF is my oil pressure?

Hell Brenx, if it rains, it pours!

The most common problem is blowing the oil gallery plugs out (if they are not converted to threaded)

Good luck - hope you get it sorted
Racer is offline   Reply With Quote
Old 06-01-2005, 18:16   #9 (permalink)
Registered User
 
xdclevo's Avatar
 
Join Date: Mar 2004
Location: Cairns
Posts: 1,946
Re: WTF is my oil pressure?

Even when my cam failed and put metal through everthing, destroying pump and bearings, i had 50 pounds pressure hot, and revving. Either the pump is totally stuffed(but you said it pumps oil in your test), or maybe a lifter in the driver side bank has jumped out, making a MAJOR bleeding point before reaching your sender.
Could your pumps bypass be shot, letting it pump oil, but not to the motor/sender area?
You may have checked all this, but just throwing some ideas.
( the only gallery plug that could cause no pressure at sender, is the front drivers side one. I think you can check those ones from looking through the distributor hole)
__________________
10.70 @ 125.00 on the black fun top
408 Cube Cleveland.
xdclevo is offline   Reply With Quote
Old 06-01-2005, 19:34   #10 (permalink)
82XE 351c
 
Join Date: Jul 2004
Location: North Coast, NSW
Posts: 627
Re: WTF is my oil pressure?

I would suggest borrowing a master gauge, one that screws into the thread for the sender, not just leaving the sender out.

-i am thinking it has more todo with pressure escaping than lack of oil
pracy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Cleveland Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:16.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.