351 windsor running rich - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-28-05, 06:22 PM Thread Starter
Registered User
 
Join Date: Oct 2004
Age: 53
Posts: 5
351 windsor running rich

Hello all.
Ok here goes I have a 351 Windsor that I cant seem to get running right.
This is not my first time sending a message on this motor but it is on this problem.
Here goes when the car gets hot its seems to run rich and fouls up the plugs.
I have been all over the map with jetting 750 dbl Demon.
I just put another carb on 750 holly vac secondary.
That still did not solve my problem with the plugs.
So what I did was a compression test.
Here is some info on motor first.
Trw 8.5 comp forged pistons, Dart Windsor Heads 64 cc.
Cam is Comp cam FW XE284H-10
Lift Intake 541 Exhaust 544
Duration &.050 240 Intake Exhaust 246
Ok here is what I found after compression test.
Please keep in mind that this test was done on a room temperature motor.

(Plug Compression ) ........... ( Condition )

#1 102 ........................ Very Black
#2 97 ........................... -----"-----
#3 105 ......................... -----"-----
#4 98 ......................... ----"------
#5 103 ........................ Running Good
#6 98 ......................... -----"-----
#7 100 ......................... -----"------
#8 102 ........................ Very Black

Yes I know it should be hot but I did a test on #1 102 hot and also # 5 103 hot no difference from cold.

OK thats it by the way the motor is Farly fresh maybe 200 miles on it.
Heads where just done also new guides and flow work.
So as you can see it driving me crazy any Ideas ???
I need help lol.
Thanks in advance Ray.
Attached Images
File Type: jpg Dsc_0697.jpg (50.7 KB, 23 views)
ve3ray is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-15-05, 02:50 AM
Registered User
 
Join Date: Feb 2005
Posts: 4
Re: 351 windsor running rich

Hi Ray,

I have a similar combo, except cast heads, I solved my problem with jetting, idle mixture adjustment, and going back to "stock" Bosch plugs.

What plugs are you using ?

What HP are you getting out if this combo anyway ?
RobertXW is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome