Can't figure it out why my EFI jerks - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-03-2006, 11:39   #1 (permalink)
Registered User
 
Join Date: May 2006
Posts: 3
Can't figure it out why my EFI jerks

Hello everyone and greetings from Finland!

This is my first post here and I hope my english is good enough to be understood.

I have a 1983 Crown Victoria LTD Country Squire, which has a 1986 302 (S)EFI engine installed in it. The car is in good condition, but has a very annoying problem. First the jerking (correct word?) occured only when I lifted my foot off the gas pedal. Now it jerks also while driving at steady speed. Also the jerks? are more violent than at first. The idle isn't rough, but it wanders. Sometimes it accelerates hard for a second without touching the pedal. Not very nice in traffic jams. The car runs very good on full throttle and in general the mileage seems to be a little bit worse than it should. For some reason the computer doesn't give any codes.

The things that have already been done:

- Someone has blocked/plugged the EGR
- I cleaned the Idle Air Bypass (IAB) valve
- The usual stuff (sparkplugs, distributor rotor, gas and air filters) have been replaced
- Throttle Position Sensor (TPS) has been adjusted to 0,97V
- I also changed the thermostat, because the engine seemed to run a little cold
- The fuel pressure was tested and everything ok there
- The timing chain and gears have been replace
- I cleaned the fuel injectors
- Changed all the intake manifold gaskets (Feel-Pro set)

Now I don't have a clue what to do next Any hints are very welcome! Thank you very much in advance!

-Jesse-
-Jesse- is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-03-2006, 16:32   #2 (permalink)
74 XB Fairmont
 
brenx's Avatar
 
Join Date: Sep 2001
Location: Cranbourne, Vic
Posts: 5,113
Re: Can't figure it out why my EFI jerks

try the plug leads. As bad leads will cause the problems your having. Remember to replace the coil lead also.
__________________
XB Fairmont (street car) 11.07@123.02mph.
brenx is offline   Reply With Quote
Old 05-03-2006, 19:57   #3 (permalink)
Registered User
 
Join Date: Jun 2005
Location: Melbourne
Age: 31
Posts: 111
Re: Can't figure it out why my EFI jerks

wats the fuel level like in the tank? sounds like fuel surge.
has it only happened recently? does it only happen on 1/4 tank?
if ur've checked fuel pressure make sure you also check flow. your fuel pump may be ok but the fuel reg might be bypassing fuel because of a seal or just wear and tear.
and one more thing if you replaced the fuel filter just remove the fuel pickup in the tank because some manufacturers put little prefilters before the pump to protect it from dirt which may be inside the tank at the end of the p/up tube.
good luck let us know how you go
ziggs is offline   Reply With Quote
Old 05-04-2006, 06:53   #4 (permalink)
Registered User
 
Join Date: May 2006
Posts: 3
Re: Can't figure it out why my EFI jerks

Forgot to mention that the plugs are ok too.

I've owned the car for 3 months now and the problem has been there all the time. Recently it has gone worse. The amount of fuel has no affect.

I don't know if the computer can be one to blame, but I'll try another one tomorrow. I'll also check the fuel pickup.

Thanks guys! I'll keep you updated.
-Jesse- is offline   Reply With Quote
Old 05-04-2006, 09:41   #5 (permalink)
Registered User
 
Freshmeat's Avatar
 
Join Date: Sep 2005
Location: Geismar, LA, USA
Age: 30
Posts: 833
Re: Can't figure it out why my EFI jerks

It sounds to me like your transmission is done for. Have you tried adjusting the TV cable? Go to your local Ford dealer and pick up the brass TV grommet (they should know what you're talking about) and check this website. If it's still doing it, you're most likely going to need a new transmission.

http://www.txchange.com/aodadj.htm

Good luck and keep us posted.
__________________

My Garage
Freshmeat is offline   Reply With Quote
Old 05-04-2006, 10:12   #6 (permalink)
Registered User
 
Join Date: May 2006
Posts: 3
Re: Can't figure it out why my EFI jerks

I really, really, really, really wish that it's not the transmission. I've had way too many of those. The tv-cable is adjusted, kickdown works great at 50mph and the shifts are good with no slippage. I recently did a full flush of the transmission and it had no effect to the jerking.

I don't say that it can't be it, but I'd like to continue by looking for the reason why the idle wanders and the car does those "automatic accelerations". If I get rid of those and car still jerks, then I'll swap or repair the transmission. What actual part or system could it be in the tranny?

Thank you for all these quick replies!
-Jesse- is offline   Reply With Quote
Old 11-27-2006, 09:32   #7 (permalink)
Registered User
 
ford79man91's Avatar
 
Join Date: Sep 2006
Location: North Vandergrift
Posts: 23
Re: Can't figure it out why my EFI jerks

Does this car have an upper plenum fuel injection system...if so check for a vacuum hose unplugged or plugged underneath your plenum...that is probably where your jerking problem is.... mine did the same thing for awhile until i noticed that the hose was undone....good luck
ford79man91 is offline   Reply With Quote
Old 11-28-2006, 00:10   #8 (permalink)
Registered User
 
jas24zzk's Avatar
 
Join Date: Jul 2005
Location: Wandin, Vic
Age: 41
Posts: 827
Re: Can't figure it out why my EFI jerks

Another one i have seen on falcons here in oz, is the Power steering pressure sensor on the rack.

If its screwed, it will send erroneous signals to the computer about a load that doesn't exist.

Cheers
Jas
jas24zzk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > Windsor Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 15:20.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.